Go Back  RCU Forums > RC Helicopters > Multi Rotor Helicopters
Reload this Page >

Pixhawk Px4 and Turnigy 9x8c v2 help?

Notices
Multi Rotor Helicopters Discuss Multi rotor RC Helicopter's here!

Pixhawk Px4 and Turnigy 9x8c v2 help?

Old 07-19-2015, 12:36 PM
  #1  
ginnz
Senior Member
Thread Starter
My Feedback: (2)
 
Join Date: Jul 2005
Location: gretna, MB, CANADA
Posts: 506
Likes: 0
Received 0 Likes on 0 Posts
Default Pixhawk Px4 and Turnigy 9x8c v2 help?

Hi guys,

Im finally coming here for help with an issue ive been working on for days. Its a bit of a long story but here goes. Recently I picked up a used 550 bumblebee quad. It had a KK 1.5 on it. I decided I wanted a Px4 so I ordered a full kit off FleaBay from goodlucksell seller. It came with all this stuff:

- 1* Pixhawk px4 2.4.6 32 bit ARM Flight Controller with shell
- 1* Buzzer module
- 1* Safety button
- 1* Anti-vibration set for pix board
- 1* PPM module
- 1* External LED light board(with USB function)
- 1* NEO-M8N GPS
- 1* Power Module XT60-plug type
- 1* Pixhawk-I2C Splitter Expand board
- 1* 3DR radio 915Mhz Data Transmission Module
- 1* mini USB cable
- 1* minimosd

Ok, I've managed to hook it all up, (minus the minumosd-they wired connections wrong) and get it mostly setup through mission planner. Now, Im at the part where im trying to setup the TX (Turnigy TGY9X). I wired up the included PPM encoder to the 9x8c v2 receiver and can see inputs moving in mission planner, BUT only if I plug the lipo in to the main power (while having the USB hooked up to PX4), AND have a BEC inline off the main lipo power feeding power into the 9x8C V2. It looks like the receiver is supposed to get power off the PPM encoder as there is a black/red/white wire off the encoder. This is where the power is supposed to come from. I cannot get mission planner to see the Rec. without power from the BEC, or cannot get the red light to come on on the Rec, without the power from the Lipo/BEC. Is this the way its supposed to work?

Can someone please help me get past this (almost last hurdle), so I can finalize all my wiring and be confident its all hooked up right. I say almost last hrdle, as the wires that they made up for the Minumosd were all spliced together wrong. I ended up boxing the OSD for now, as im not using FPV yet, and just hooked the 915 mghz TX straight up to the PX4 telem port for now, which is working fine. This has been a long build, as the included usb cable was faulty, so I lost hours trying to configure everything, before I figured out they sent a bad cable....:-(

Anyways, thanks for now, and plese shed some light on this?
ginnz.
Old 04-15-2016, 05:58 AM
  #2  
aopen3434
 
Join Date: Mar 2012
Location: toronto, ON, CANADA
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
Default

you need to power the receiver from BEC as well as the PPM encoder ! pix hawk has no power output to the receiver.
regards

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service -

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.