Go Back  RCU Forums > RC Airplanes > RC Jets > Turbine Clinic > PST Jets
 J1600R Over heat and shutdown ! >

J1600R Over heat and shutdown !

Notices
PST Jets Direct support for PST Jets Turbines.

J1600R Over heat and shutdown !

Old 09-15-2010, 12:12 AM
  #1  
Junior Member
Thread Starter
 
Join Date: Jul 2008
Location: Hochiminh, VIETNAM
Posts: 5
Likes: 0
Received 0 Likes on 0 Posts
Default J1600R Over heat and shutdown !

Dear All,
I've just bought a new jet engine from PST. It is J1600R. When I started the engine, everything was fine and the temperature was about 560-600 degree C at the idle RPM (35.000 rpm). Then I started to power up, it was fine but at the top of RPM ( 120.000rpm) the engine became over heat and shutdown automatically at the 840 degree C. After that, I checked the temperature sensor and I made sure that it stayed correct position (about 5mm in the tail cone). I tried again but the engine was over heat again. Then I tried to pull the temperature sensor to 2mm in tail cone, unfortunately, the problem has not been solved. Would you please help me to solve this problem ?

Thanks All,
Eric Trinh
Old 09-15-2010, 02:10 AM
  #2  
Junior Member
 
Join Date: Dec 2009
Location: Bangkok, THAILAND
Posts: 20
Likes: 0
Received 0 Likes on 0 Posts
Default RE: J1600R Over heat and shutdown !


<p class="MsoNormal" style="MARGIN: 0cm 0cm 0pt"><font size="3"><font face="Calibri">Hi Eric,

</p></font></font></p><p class="MsoNormal" style="MARGIN: 0cm 0cm 0pt"><font size="3"><font face="Calibri">Nice to hear from our neighbor. Try to set the EGT Probe about 1mm. <span style="mso-spacerun: yes"> </span>Normally all the new engines from PST will have factory preset by special mount attached to the tail cone. What have happen to that one?

</p></font></font></p><p class="MsoNormal" style="MARGIN: 0cm 0cm 0pt"><font size="3"><font face="Calibri">Kumpol

</p></font></font></p><p class="MsoNormal" style="MARGIN: 0cm 0cm 0pt"><font size="3"><font face="Calibri">PSTJETS THAILAND

</p></font></font></p>
Old 09-15-2010, 08:51 AM
  #3  
Junior Member
Thread Starter
 
Join Date: Jul 2008
Location: Hochiminh, VIETNAM
Posts: 5
Likes: 0
Received 0 Likes on 0 Posts
Default RE: J1600R Over heat and shutdown !


ORIGINAL: kumpol


<p class=''MsoNormal'' style=''MARGIN: 0cm 0cm 0pt''><font size=''3''><font face=''Calibri''>Hi Eric,

</p></font></font></p><p class=''MsoNormal'' style=''MARGIN: 0cm 0cm 0pt''><font size=''3''><font face=''Calibri''>Nice to hear from our neighbor. Try to set the EGT Probe about 1mm. <span style=''mso-spacerun: yes''> </span>Normally all the new engines from PST will have factory preset by special mount attached to the tail cone. What have happen to that one?

</p></font></font></p><p class=''MsoNormal'' style=''MARGIN: 0cm 0cm 0pt''><font size=''3''><font face=''Calibri''>Kumpol

</p></font></font></p><p class=''MsoNormal'' style=''MARGIN: 0cm 0cm 0pt''><font size=''3''><font face=''Calibri''>PSTJETS THAILAND

</p></font></font></p>

The mouting still fine, sir . I've tried to set about 2mm,but couldn't solve the problem. Tomorrow I will try with 1mm setting and I will report you later , is it ok ?
Old 09-23-2010, 10:30 PM
  #4  
Junior Member
Thread Starter
 
Join Date: Jul 2008
Location: Hochiminh, VIETNAM
Posts: 5
Likes: 0
Received 0 Likes on 0 Posts
Default RE: J1600R Over heat and shutdown !


ORIGINAL: kumpol


<p class=''MsoNormal'' style=''MARGIN: 0cm 0cm 0pt''><font size=''3''><font face=''Calibri''>Hi Eric,

</p></font></font></p><p class=''MsoNormal'' style=''MARGIN: 0cm 0cm 0pt''><font size=''3''><font face=''Calibri''>Nice to hear from our neighbor. Try to set the EGT Probe about 1mm. <span style=''mso-spacerun: yes''> </span>Normally all the new engines from PST will have factory preset by special mount attached to the tail cone. What have happen to that one?

</p></font></font></p><p class=''MsoNormal'' style=''MARGIN: 0cm 0cm 0pt''><font size=''3''><font face=''Calibri''>Kumpol

</p></font></font></p><p class=''MsoNormal'' style=''MARGIN: 0cm 0cm 0pt''><font size=''3''><font face=''Calibri''>PSTJETS THAILAND

</p></font></font></p>
Dear kumpol,
I set the EGT Probe to 1mm but I could not solve the problem. The engine still overheat. Should I send the engine back to Thailand ? If I should, would you please send me the PST address infor, therefore I can send it to you.
Old 10-22-2010, 01:10 AM
  #5  
My Feedback: (69)
 
rcguy!'s Avatar
 
Join Date: Jan 2002
Location: Chesterland , OH
Posts: 2,850
Received 1 Like on 1 Post
Default RE: J1600R Over heat and shutdown !


ORIGINAL: ty_edge_540t


ORIGINAL: kumpol


<p class=''MsoNormal'' style=''MARGIN: 0cm 0cm 0pt''><font size=''3''><font face=''Calibri''>Hi Eric,

</p></font></font></p><p class=''MsoNormal'' style=''MARGIN: 0cm 0cm 0pt''><font size=''3''><font face=''Calibri''>Nice to hear from our neighbor. Try to set the EGT Probe about 1mm. <span style=''mso-spacerun: yes''> </span>Normally all the new engines from PST will have factory preset by special mount attached to the tail cone. What have happen to that one?

</p></font></font></p><p class=''MsoNormal'' style=''MARGIN: 0cm 0cm 0pt''><font size=''3''><font face=''Calibri''>Kumpol

</p></font></font></p><p class=''MsoNormal'' style=''MARGIN: 0cm 0cm 0pt''><font size=''3''><font face=''Calibri''>PSTJETS THAILAND

</p></font></font></p>
Dear kumpol,
I set the EGT Probe to 1mm but I could not solve the problem. The engine still overheat. Should I send the engine back to Thailand ? If I should, would you please send me the PST address infor, therefore I can send it to you.

Ever get an answer to your question?
Old 03-24-2012, 11:38 PM
  #6  
 
Join Date: Feb 2010
Location: Escholzmatt, SWITZERLAND
Posts: 32
Received 1 Like on 1 Post
Default RE: J1600R Over heat and shutdown !

Hi all

Also mine PSTTurbine J1600R overheats. I crashed two jets after take off because the turbine flamed out. Both times the shutdown data said temperature 804&deg; and 803&deg;C. Did PST fix this problem?
After I contacted PST a year ago after the first jet crashed, they didn't mention the problem unfortunately. Now I crashed two jets and lost confidence of the J1600R turbine.

Anyone the same experience or further information about the reliability of the J1600R turbine?

Thanks

Manuel

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On


Thread Tools
Search this Thread

Contact Us - Manage Preferences Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.