RCU Forums

RCU Forums (https://www.rcuniverse.com/forum/)
-   PST Jets (https://www.rcuniverse.com/forum/pst-jets-164/)
-   -   J1600R Over heat and shutdown ! (https://www.rcuniverse.com/forum/pst-jets-164/10003134-j1600r-over-heat-shutdown.html)

ty_edge_540t 09-15-2010 12:12 AM

J1600R Over heat and shutdown !
 
Dear All,
I've just bought a new jet engine from PST. It is J1600R. When I started the engine, everything was fine and the temperature was about 560-600 degree C at the idle RPM (35.000 rpm). Then I started to power up, it was fine but at the top of RPM ( 120.000rpm) the engine became over heat and shutdown automatically at the 840 degree C. After that, I checked the temperature sensor and I made sure that it stayed correct position (about 5mm in the tail cone). I tried again but the engine was over heat again. Then I tried to pull the temperature sensor to 2mm in tail cone, unfortunately, the problem has not been solved. Would you please help me to solve this problem ?

Thanks All,
Eric Trinh

kumpol 09-15-2010 02:10 AM

RE: J1600R Over heat and shutdown !
 

<p class="MsoNormal" style="MARGIN: 0cm 0cm 0pt"><font size="3"><font face="Calibri">Hi Eric,

</p></font></font></p><p class="MsoNormal" style="MARGIN: 0cm 0cm 0pt"><font size="3"><font face="Calibri">Nice to hear from our neighbor. Try to set the EGT Probe about 1mm. <span style="mso-spacerun: yes"> </span>Normally all the new engines from PST will have factory preset by special mount attached to the tail cone. What have happen to that one?

</p></font></font></p><p class="MsoNormal" style="MARGIN: 0cm 0cm 0pt"><font size="3"><font face="Calibri">Kumpol

</p></font></font></p><p class="MsoNormal" style="MARGIN: 0cm 0cm 0pt"><font size="3"><font face="Calibri">PSTJETS THAILAND

</p></font></font></p>

ty_edge_540t 09-15-2010 08:51 AM

RE: J1600R Over heat and shutdown !
 


ORIGINAL: kumpol


<p class=''MsoNormal'' style=''MARGIN: 0cm 0cm 0pt''><font size=''3''><font face=''Calibri''>Hi Eric,

</p></font></font></p><p class=''MsoNormal'' style=''MARGIN: 0cm 0cm 0pt''><font size=''3''><font face=''Calibri''>Nice to hear from our neighbor. Try to set the EGT Probe about 1mm. <span style=''mso-spacerun: yes''> </span>Normally all the new engines from PST will have factory preset by special mount attached to the tail cone. What have happen to that one?

</p></font></font></p><p class=''MsoNormal'' style=''MARGIN: 0cm 0cm 0pt''><font size=''3''><font face=''Calibri''>Kumpol

</p></font></font></p><p class=''MsoNormal'' style=''MARGIN: 0cm 0cm 0pt''><font size=''3''><font face=''Calibri''>PSTJETS THAILAND

</p></font></font></p>

The mouting still fine, sir . I've tried to set about 2mm,but couldn't solve the problem. Tomorrow I will try with 1mm setting and I will report you later , is it ok ?

ty_edge_540t 09-23-2010 10:30 PM

RE: J1600R Over heat and shutdown !
 


ORIGINAL: kumpol


<p class=''MsoNormal'' style=''MARGIN: 0cm 0cm 0pt''><font size=''3''><font face=''Calibri''>Hi Eric,

</p></font></font></p><p class=''MsoNormal'' style=''MARGIN: 0cm 0cm 0pt''><font size=''3''><font face=''Calibri''>Nice to hear from our neighbor. Try to set the EGT Probe about 1mm. <span style=''mso-spacerun: yes''> </span>Normally all the new engines from PST will have factory preset by special mount attached to the tail cone. What have happen to that one?

</p></font></font></p><p class=''MsoNormal'' style=''MARGIN: 0cm 0cm 0pt''><font size=''3''><font face=''Calibri''>Kumpol

</p></font></font></p><p class=''MsoNormal'' style=''MARGIN: 0cm 0cm 0pt''><font size=''3''><font face=''Calibri''>PSTJETS THAILAND

</p></font></font></p>
Dear kumpol,
I set the EGT Probe to 1mm but I could not solve the problem. The engine still overheat. Should I send the engine back to Thailand ? If I should, would you please send me the PST address infor, therefore I can send it to you.

rcguy! 10-22-2010 01:10 AM

RE: J1600R Over heat and shutdown !
 


ORIGINAL: ty_edge_540t



ORIGINAL: kumpol


<p class=''MsoNormal'' style=''MARGIN: 0cm 0cm 0pt''><font size=''3''><font face=''Calibri''>Hi Eric,

</p></font></font></p><p class=''MsoNormal'' style=''MARGIN: 0cm 0cm 0pt''><font size=''3''><font face=''Calibri''>Nice to hear from our neighbor. Try to set the EGT Probe about 1mm. <span style=''mso-spacerun: yes''> </span>Normally all the new engines from PST will have factory preset by special mount attached to the tail cone. What have happen to that one?

</p></font></font></p><p class=''MsoNormal'' style=''MARGIN: 0cm 0cm 0pt''><font size=''3''><font face=''Calibri''>Kumpol

</p></font></font></p><p class=''MsoNormal'' style=''MARGIN: 0cm 0cm 0pt''><font size=''3''><font face=''Calibri''>PSTJETS THAILAND

</p></font></font></p>
Dear kumpol,
I set the EGT Probe to 1mm but I could not solve the problem. The engine still overheat. Should I send the engine back to Thailand ? If I should, would you please send me the PST address infor, therefore I can send it to you.

Ever get an answer to your question?

Turbine2010 03-24-2012 11:38 PM

RE: J1600R Over heat and shutdown !
 
Hi all

Also mine PSTTurbine J1600R overheats. I crashed two jets after take off because the turbine flamed out. Both times the shutdown data said temperature 804&deg; and 803&deg;C. Did PST fix this problem?
After I contacted PST a year ago after the first jet crashed, they didn't mention the problem unfortunately. Now I crashed two jets and lost confidence of the J1600R turbine.

Anyone the same experience or further information about the reliability of the J1600R turbine?

Thanks

Manuel


All times are GMT -8. The time now is 05:22 PM.


Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.