RCU Forums

RCU Forums (https://www.rcuniverse.com/forum/)
-   PST Jets (https://www.rcuniverse.com/forum/pst-jets-164/)
-   -   High temp shutdown PST1300R (https://www.rcuniverse.com/forum/pst-jets-164/9560982-high-temp-shutdown-pst1300r.html)

mun_iz 03-07-2010 05:30 AM

High temp shutdown PST1300R
 
I have a PST1300R which I bought brand new ard 3 years back. I had only done a couple of bench runs on it before shelving it.

Just last weekend, I managed to maiden a JL F15 with the engine. On the 2nd and 3rd flight, the engine flame out right after take off when it was on full throttle... When I checked the data on the display, it showed a shut down temperature of 803-806 deg C. startting the engine on the ground with the top hatch opened, the idling temp was ard 540-560 deg C and full throttle temperature was at 780-790 deg C.

We checked and found that the thermocouple had been inserted about 5mm into the engine. We pulled it out slightly and only left around 2mm inside the nozzle. At this position, idle temp was 430 deg C and full throttle temp was 670 deg C. On the 4th flight, the engine flames out again on take off. This time I wasn't as fortunate and the plane suffered severe damage to its structure. Shut down temperature showed 250 deg C. We found that the thermocouple had slid out of the nozzle. My questions are as follows:

1) for the flame out at 800 deg C, was this a over temp shut down?

2) Were we correct to had readjusted the thermocouple to get lower temperatures? what is the appropriate lenght of thermocouple that should had been inserted into the engine?

3) I think I had seen a pic of a PST engine (i think was the 1600R) where the thermocuple tip is held by a small clip that is bolted onto the exhaust nozzle. Is this available for the 1300R? Can I buy the clip and install it myself?

Thanks.

swansons 03-07-2010 07:34 AM

RE: High temp shutdown PST1300R
 
Send an inquiry to B777 here on RCU. He can answer all your questions.

John S.

B777 03-07-2010 07:51 AM

RE: High temp shutdown PST1300R
 
The probe must have been pushed in during the storage handling. Answers in Bold below.

1) for the flame out at 800 deg C, was this a over temp shut down? YES

2) Were we correct to had readjusted the thermocouple to get lower temperatures? what is the appropriate lenght of thermocouple that should had been inserted into the engine? 2mm insertion. You are correct to readjust the EGT probe, however, the technique was not correct since there wasn't enough spring tension which allowed the probe to spring out.

3) I think I had seen a pic of a PST engine (i think was the 1600R) where the thermocuple tip is held by a small clip that is bolted onto the exhaust nozzle. Is this available for the 1300R? Can I buy the clip and install it myself? You need to drill the tail cone in order to insert the probe securing clip. Please contact [email protected] for assistance.

Sorry to hear about the damage...B777

mun_iz 03-07-2010 08:22 AM

RE: High temp shutdown PST1300R
 
Hi all,

Thanks for the replies. I had e-mailed PST rgding the clip.


All times are GMT -8. The time now is 09:04 AM.


Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.