Go Back  RCU Forums > RC Airplanes > Questions and Answers
Reload this Page >

Strange servo behaviour

Notices
Questions and Answers If you have general RC questions or answers discuss it here.

Strange servo behaviour

Old 01-26-2019, 06:39 AM
  #1  
Christiaan22
Thread Starter
 
Join Date: Feb 2018
Posts: 23
Likes: 0
Received 0 Likes on 0 Posts
Default Strange servo behaviour

Goodday,

i have a pilot rc predator with mks 737hv servo's. Power distributions is via a powerbox professional. All the servo's are powered by the powerbox as well as the flaps servo's where the problem is. Radio is a futaba t14sg with futaba rx. The problem: the flaps move over time. At startup the flaps are not completly centered but after a minute or so it is centered. Control is via a 3-way switch for Up-take off-landing configuration. And it is strange only the flap servo's will move over time and at powerbox startup it is not centered, even after setup to center the flap servo's and recycle power. What can cause this slowly servo movement?

best regards,
christiaan
Old 02-11-2019, 08:36 AM
  #2  
Appowner
Banned
 
Join Date: Nov 2017
Posts: 1,016
Likes: 0
Received 0 Likes on 0 Posts
Default

Put the RX on the bench and hook up a basic system with battery, the flap servo (s) and the Tx. Power this up and watch. See if the same symptoms occur. If nothing happens, add one more item from the plane and test again. Keep going until the problem shows itself. Last item added is probably the culprit. I expect you'll find it sooner rather than later.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.