Go Back  RCU Forums > RC Airplanes > Questions and Answers
Reload this Page >

Squealing Saito?

Notices
Questions and Answers If you have general RC questions or answers discuss it here.

Squealing Saito?

Old 08-18-2008, 08:30 PM
  #1  
Jester241
Senior Member
Thread Starter
 
Jester241's Avatar
 
Join Date: Aug 2007
Location: MCALISTERVILLE, PA
Posts: 683
Likes: 0
Received 0 Likes on 0 Posts
Default Squealing Saito?

My Saito 125 is making a pretty bad squealing sound I believe from the front part of the motor. I thought maybe it was just the backplate hub thing rubbing something,but I'm now thinking its the bearing. Its seems if I hold the plane upside down and let the oil run into the bearing it fixing it for awhile. The motor only has about 20 flights on it. Have any of you ever had this problem? If it is the bearing,how do you go about replacing it? I cant even get the backplate hub thing off. It seems to be pressed on or held in place by retaining clips or something. Thoughts?
Old 08-18-2008, 08:39 PM
  #2  
The Ghost
 
The Ghost's Avatar
 
Join Date: Mar 2004
Location: UlladullaNSW, AUSTRALIA
Posts: 1,846
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Squealing Saito?

Question 1, What oil do you use?
Question 2, How long has it been since last use?

The packplate Hub thingy is the prop driver, it is fitted on the shaft with a tapered collet, a puller is the best way to remove it, the cam timing is the worst thing with reassembly, other than that is is just another model engine.

Cheers
Old 08-18-2008, 08:49 PM
  #3  
Jester241
Senior Member
Thread Starter
 
Jester241's Avatar
 
Join Date: Aug 2007
Location: MCALISTERVILLE, PA
Posts: 683
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Squealing Saito?

I used Byrons fuel 15%. It squealed awhile back alittle when it was almost new,but nothing I worried about,but I havent heard it do it in quite some time until today when we leaned the engine a bit(coincidence?) because it was running pretty rich. Like I said before....just figured it was that prop driver rubbing. I store the plane in the shop nose up like I do all my planes,so that might have something to do with it,but I've never had problems with any other planes. And this engine has never set more then a couple weeks between flights.
Old 08-18-2008, 11:49 PM
  #4  
The Ghost
 
The Ghost's Avatar
 
Join Date: Mar 2004
Location: UlladullaNSW, AUSTRALIA
Posts: 1,846
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Squealing Saito?

Hard to say with out looking at the engine. It could be a bad bearing, would have to pull the motor down to check anyway so it may as well be replaced. Have replaced quite a few bearings in the larger size Satios but only after many hours of work and usually it is the rear bearing that is shot.

Cheers
Old 08-19-2008, 07:52 AM
  #5  
jetmech05
 
Join Date: Jul 2005
Location: Jacksonville, FL
Posts: 4,855
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Squealing Saito?

from the front of the engine I'll bet you have a bad bearing
Old 08-19-2008, 11:37 AM
  #6  
mscic-RCU
Senior Member
My Feedback: (6)
 
mscic-RCU's Avatar
 
Join Date: Mar 2002
Location: New London, OH
Posts: 1,237
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Squealing Saito?

If it only has 20 flights on it, is it still in warranty? If so you might want to send it back to Horizon for repair. If it is out of waranty, might want to find someone in the club to help you tear it down if you are inexperienced at this.
Old 08-19-2008, 03:11 PM
  #7  
Jester241
Senior Member
Thread Starter
 
Jester241's Avatar
 
Join Date: Aug 2007
Location: MCALISTERVILLE, PA
Posts: 683
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Squealing Saito?

Should still be under warrany,just bought it this past winter. I will likely send it back,I just hate to have my favorite plane down for weeks waiting to get it back. But thats probably what I'll do if it still does it next time I fly it. I'd enjoy working on an engine,but its probably best that since this is my most important engine at the moment. I can see them telling me they didnt find anything wrong with it since it only does it sometimes(more often then not though lately I guess),and it gets worse as the engine runs for awhile. Oh well,we'll see.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.