Go Back  RCU Forums > RC Airplanes > Questions and Answers
Reload this Page >

OS max 40 run problems

Notices
Questions and Answers If you have general RC questions or answers discuss it here.

OS max 40 run problems

Old 08-23-2008, 10:54 AM
  #1  
franciscan
Member
Thread Starter
 
Join Date: Nov 2002
Location: Exeter, UNITED KINGDOM
Posts: 82
Likes: 0
Received 0 Likes on 0 Posts
Default OS max 40 run problems

Hi All
I have a new OS Max 40 FSR engine which I have had in its box unused for about 30 years and have just recently put this engine into a 60" vintage a/c to run it in and get it ready for another plane. I ran four tanks of fuel through it on the ground gradually leaning it out ready to fly. I have had about 7 or 8 flights with it running ok. Recently it has run up to full power ok on the ground and idles well, with a quick throttle open/shut routine. However in the air the engine tends to cut out or splutter when opening up after a touch and go following a short aproach with the engine at idle.
This week I added an extention to the needle valve to clear the nose by soldering a short piece of wire to the end of the needle valve. Since then the engine has refused to power up and cuts out anyware after mid range. I have changed the fuel tank and all fuel tubes and cleaned out the fuel filter but this made no difference. I have blown out the needle valve entry with high pressure air. The needle setting has been at 2 turns since new. Can anyone give me any pointers to my problems please.
John
Old 08-23-2008, 01:11 PM
  #2  
aerowoof
 
Join Date: Jun 2006
Location: pembroke, NH
Posts: 2,962
Likes: 0
Received 1 Like on 1 Post
Default RE: OS max 40 run problems

does your needle have an o-ring on it?if so try replacing it.if not try a new needle valve as they are 2 piece and you could have moved the needle part in relation to the threads when adding the extension
Old 08-25-2008, 07:55 AM
  #3  
franciscan
Member
Thread Starter
 
Join Date: Nov 2002
Location: Exeter, UNITED KINGDOM
Posts: 82
Likes: 0
Received 0 Likes on 0 Posts
Default RE: OS max 40 run problems

Thanks Aerowoof
This is an old engine and I am trying to source spare needle valve.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.