Notices
Questions and Answers If you have general RC questions or answers discuss it here.

Buzzing servos

Old 03-25-2010, 04:38 PM
  #1  
albinowino
Junior Member
Thread Starter
 
Join Date: Aug 2007
Location: Washington, IN
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Default Buzzing servos

Hello: I am currently building a GP38% extra 330S and have installed Futaba S9156 servos into the elavator and when I have them hooked up they have a buzzing noise when they at neutral. Is this the normal for digital servos?? Thank you in advance. Bruce
Old 03-25-2010, 04:45 PM
  #2  
The Ghost
 
The Ghost's Avatar
 
Join Date: Mar 2004
Location: UlladullaNSW, AUSTRALIA
Posts: 1,846
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Buzzing servos

YES, because the weight of the flight surface is loading the servo. You may also have a slight binding of the surface that the servo is still trying to find center, apply a slight pressure to the surface and see if it stops.

Cheers
Old 03-25-2010, 06:50 PM
  #3  
albinowino
Junior Member
Thread Starter
 
Join Date: Aug 2007
Location: Washington, IN
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Buzzing servos

hello: Thank you for the response, yes when i apply light pressure to it. It does stop buzzing. This is my first large scale project and I am just not sure about some things, Thank you again. Bruce
Old 05-12-2010, 04:55 PM
  #4  
gvf1994
Member
 
Join Date: Mar 2007
Location: Encino , CA
Posts: 33
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Buzzing servos

I Have a kinda same question. Although mine servos are not digital they are still making a buzzing noise when I turn my transmitter on. I have a hitec receiver and servos, and using futaba transmitter. Does that could make a difference? My plane is Waco 60 and flight control surfaces moved relatively easy. I checked it manually and didn't notice any binding. I replaced a switch and battery as a precautionary action. At this point any advice will be helpful. Thanks
Old 05-12-2010, 05:28 PM
  #5  
Top_Gunn
My Feedback: (6)
 
Join Date: Jun 2005
Location: Granger, IN
Posts: 2,145
Likes: 0
Received 2 Likes on 1 Post
Default RE: Buzzing servos

I had a problem with buzzing Hitec servos. Hitec suggested loosening the screws on the bottom of the case, just a little. Worked like a charm!
Old 05-12-2010, 06:58 PM
  #6  
gvf1994
Member
 
Join Date: Mar 2007
Location: Encino , CA
Posts: 33
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Buzzing servos

Thanks will try

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.