Notices

canopy failure on 102" yak

 
Old 03-08-2009, 04:34 PM
  #1  
thaus
Member
Thread Starter
My Feedback: (2)
 
Join Date: Nov 2004
Location: vero beach, FL
Posts: 59
Likes: 0
Received 0 Likes on 0 Posts
Default canopy failure on 102" yak

On my 4th day of flying my 2 week old Gen IV 102 , the canopy ripped off. I landed and found all 4 screws still in position. The plane had never been in a power dive or even 3D much. The cause must be a design or manufacturing error. What is my remedy and has this been a common problem? Perhaps there is too much flex in the fuse, or there is a weak point along the canopy rails.

If it is common, what strengthening is recommended for a new canopy?
thaus is offline  
Old 03-08-2009, 08:16 PM
  #2  
Rezagh
Senior Member
My Feedback: (73)
 
Join Date: Jun 2004
Location: Rancho Santa MargaritaCA
Posts: 1,915
Likes: 0
Received 0 Likes on 0 Posts
Default RE: canopy failure on 102" yak

Sorry to hear about that. Please call QQAC to see if they canopy. I think it had lack of glue. On the new canopy hit the tristocks, with odorless CA and let it soak, don't use kicker!

You are not at fault nor it is a design issue, just lack of glue I believe.

Thank you,
Reza
Rezagh is offline  
 

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.