Notices
Radio Manufacturer Direct Support Direct Reps from the largest radio manufacturers are here to answer your questions.

Futaba T14SG linking problem

Old 03-22-2022, 07:27 PM
  #1  
supcan
Thread Starter
 
Join Date: Aug 2005
Location: Bakersfield, CA
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Unhappy Futaba T14SG linking problem

I have brought a Futaba T14Sg that I haven't used for a bout 6 months. It has been good to me in the past but now it has lost all links to the models and will not let me relink to any of my receivers My most common is the R617FS. I know the receivers are ok as they link with my old 10CAP
Has anybody had this problem and found a solution? I am hoping to avoid sending it to Futaba USA as their turnaround time is terrible
Old 03-23-2022, 03:53 AM
  #2  
A. J. Clark
 
A. J. Clark's Avatar
 
Join Date: Mar 2004
Location: Craigville, IN
Posts: 736
Received 23 Likes on 22 Posts
Default

There's a Futaba direct support forum here where you will more likely get answers. Post there and give your linking procedure.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service -

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.