Notices
RC 1/8th Scale Buggies Discuss the ever popular category of 1/8th scale rc buggies in this forum!

XTM Xterminator help

Old 10-01-2007, 08:37 PM
  #1  
nobrainedbanana
Junior Member
Thread Starter
 
Join Date: Sep 2007
Location: Henderson, NV
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default XTM Xterminator help

I am sorry to bog down a forum with a noob question but here goes. My wife and I both bought xtm xterminators and hers worked fine and in typical fashion...min didnt. Had an engine replace and now have the bigger xtm 457engine. Hobby People doesn't like us because we are new and refuse to assist us so they made us break in my engine. Half way through break in...I noticed my car , in a way, locked up. It didnt roll freely....seems the gears dont let it roll. I am not an expert on engines and need any help...should I try another Hobby people. Do they do reairs. Seems to me they hate to be bothered with this. Also.....while I was trying to break it in...the vehicle doesnt run idle....It wants to shoot off as soon as I start it. I turn on the car and radio so it isnt that problem . We both have xtm sure starts in place of the pull starts and when I stick the starter in to crank the vehicle rolls forward as well....if that makes sense. I can get the engine started...but It still rolls high speed as if I gassed it and usually whn i apply the bbrake it stalls but if it doesnt...when I release the brake it is back at running high speed as if I am applying thottle. I have tried everything from changing the idle setting....setting the valves at where they are suppose to be and EVERYTHING....but i am not good at this. I feel frustrated for not knowing what to do even though I have basic knowledge at this and really do not know what to do as my wife has wasted 400+ on this gift for me for my birthday (sept 21). Is the engine messed up? Did I miss something? Is there somewhere I can take this? or is it to late? I enjoyed my car with its first engine and it ran really good...but we got blamed for that engine failing when we didnt do anything to adjust it....when we were told we did move valves. I apologize for the long thread but I really want to have a nice weekend car just to play around with with my wife. Thank you.
Old 10-01-2007, 11:22 PM
  #2  
thopper
Senior Member
 
Join Date: Nov 2004
Location: Fullerton, CA
Posts: 746
Likes: 0
Received 0 Likes on 0 Posts
Default RE: XTM Xterminator help

Hobby people has great marketing and poor products...you are a victim. Dont buy xtm or Airtronic products ...as yo have discovered it is a bad decision. Get your money back anyway you can and start over.
Old 10-02-2007, 01:15 AM
  #3  
DriftProjectR
Senior Member
 
DriftProjectR's Avatar
 
Join Date: Jan 2007
Location: Sin City, NV
Posts: 567
Likes: 0
Received 0 Likes on 0 Posts
Default RE: XTM Xterminator help

ORIGINAL: nobrainedbanana

I am sorry to bog down a forum with a noob question but here goes. My wife and I both bought xtm xterminators and hers worked fine and in typical fashion...min didnt. Had an engine replace and now have the bigger xtm 457engine. Hobby People doesn't like us because we are new and refuse to assist us so they made us break in my engine. Half way through break in...I noticed my car , in a way, locked up. It didnt roll freely....seems the gears dont let it roll. I am not an expert on engines and need any help...should I try another Hobby people. Do they do reairs. Seems to me they hate to be bothered with this. Also.....while I was trying to break it in...the vehicle doesnt run idle....It wants to shoot off as soon as I start it. I turn on the car and radio so it isnt that problem . We both have xtm sure starts in place of the pull starts and when I stick the starter in to crank the vehicle rolls forward as well....if that makes sense. I can get the engine started...but It still rolls high speed as if I gassed it and usually whn i apply the bbrake it stalls but if it doesnt...when I release the brake it is back at running high speed as if I am applying thottle. I have tried everything from changing the idle setting....setting the valves at where they are suppose to be and EVERYTHING....but i am not good at this. I feel frustrated for not knowing what to do even though I have basic knowledge at this and really do not know what to do as my wife has wasted 400+ on this gift for me for my birthday (sept 21). Is the engine messed up? Did I miss something? Is there somewhere I can take this? or is it to late? I enjoyed my car with its first engine and it ran really good...but we got blamed for that engine failing when we didnt do anything to adjust it....when we were told we did move valves. I apologize for the long thread but I really want to have a nice weekend car just to play around with with my wife. Thank you.
hey buddy, i use to work at hobby people on tropicana and boulder (probably were you wife bought it). i quite there since they had a bad business ethic (tried to put one over a lot of people). i had worked there for a couple of months (about 4). so if you need help, i have a lot of experience with the xt2 and i live in Henderson as well. . let me know, ill give you a hand and get you running.

ORIGINAL:thopper

Dont buy xtm or Airtronic products
i agree with you about xtm, but with airtornics? they have one of the best or not the best radios out there.

plus, hobby people/hobby shack/global hobby
just bought the company that is based out of japan. it was bought for revenue, not to take over. [sm=72_72.gif]
Old 10-02-2007, 09:10 AM
  #4  
thopper
Senior Member
 
Join Date: Nov 2004
Location: Fullerton, CA
Posts: 746
Likes: 0
Received 0 Likes on 0 Posts
Default RE: XTM Xterminator help

Try getting a snawa servo fixed these days by Hobby People....good luck!
Old 10-02-2007, 11:04 AM
  #5  
DriftProjectR
Senior Member
 
DriftProjectR's Avatar
 
Join Date: Jan 2007
Location: Sin City, NV
Posts: 567
Likes: 0
Received 0 Likes on 0 Posts
Default RE: XTM Xterminator help


ORIGINAL: thopper

Try getting a snawa servo fixed these days by Hobby People....good luck!
your suppose to send it back the manufacturer? maybe if you read the little instructions that came with the servos you would know?
Old 10-02-2007, 01:56 PM
  #6  
pete8541
 
Join Date: Jan 2006
Location: sauk city, WI
Posts: 226
Likes: 0
Received 0 Likes on 0 Posts
Default RE: XTM Xterminator help

Sounds like you may need to check your clutch bearings.
If you are running the Higtec radio that comes with the xtm , throw it away. I have had five and have had five go bad.

If the car is binding, I suggest that you take it apart and become familiar with it and put it back together with loctite and the proper lube.
Old 10-02-2007, 05:57 PM
  #7  
rcboy93
Senior Member
 
Join Date: May 2006
Location: simi valley, CA
Posts: 311
Likes: 0
Received 0 Likes on 0 Posts
Default RE: XTM Xterminator help

ok
1. xtm is not bad as long as you have the proper set up but thats with any car (beside the mammoth st!!!! hate it[&o]).i have 2 xt2 i race 1 and use 1 as my back up. I have come in 1st to 5th outa 10-15 people in all my races. the only reason most pros dont race them is cause hobby people is the stocker 4 evry thing 4 xtm if they were world wide i bet u alot more people would race them.and cause there r $250 dosent mean ur gettin a bad deal. if u guys wana go spend bout $500 on a rtr go ahead.i mean ill do it once and a while.

i dont mean to sound like an @$$. i just dont like when people BAG on xtm cause there cheaper than any other car!!![:@]

2.i wouldent recremend goin to hobby people if ur a noooooob i would go to a diffrent hobby shop if i were u if u would like to try another hobby people u would be lucky to get 1 to evan get 1 to evan touch ur car
Old 10-02-2007, 06:03 PM
  #8  
jonnymac
Senior Member
 
Join Date: Jan 2003
Location: leicester, UNITED KINGDOM
Posts: 2,116
Likes: 0
Received 0 Likes on 0 Posts
Default RE: XTM Xterminator help

Whilst I agree about XTM products, I cannot agree on airtronics.
They are made by sanwa and my servo has provided nothing but exemplory service.
I also use sanwa/airtronics electronics on my plane for 5 years and never had a single problem.
Old 10-02-2007, 11:05 PM
  #9  
Da Smak
Banned
 
Join Date: Feb 2004
Location: North of the, , UNITED KINGDOM
Posts: 6,058
Likes: 0
Received 0 Likes on 0 Posts
Default RE: XTM Xterminator help


ORIGINAL: nobrainedbanana

I am sorry to bog down a forum with a noob question but here goes. My wife and I both bought xtm xterminators and hers worked fine and in typical fashion...min didnt. Had an engine replace and now have the bigger xtm 457engine. Hobby People doesn't like us because we are new and refuse to assist us so they made us break in my engine. Half way through break in...I noticed my car , in a way, locked up. It didnt roll freely....seems the gears dont let it roll. I am not an expert on engines and need any help...should I try another Hobby people. Do they do reairs. Seems to me they hate to be bothered with this. Also.....while I was trying to break it in...the vehicle doesnt run idle....It wants to shoot off as soon as I start it. I turn on the car and radio so it isnt that problem . We both have xtm sure starts in place of the pull starts and when I stick the starter in to crank the vehicle rolls forward as well....if that makes sense. I can get the engine started...but It still rolls high speed as if I gassed it and usually whn i apply the bbrake it stalls but if it doesnt...when I release the brake it is back at running high speed as if I am applying thottle. I have tried everything from changing the idle setting....setting the valves at where they are suppose to be and EVERYTHING....but i am not good at this. I feel frustrated for not knowing what to do even though I have basic knowledge at this and really do not know what to do as my wife has wasted 400+ on this gift for me for my birthday (sept 21). Is the engine messed up? Did I miss something? Is there somewhere I can take this? or is it to late? I enjoyed my car with its first engine and it ran really good...but we got blamed for that engine failing when we didnt do anything to adjust it....when we were told we did move valves. I apologize for the long thread but I really want to have a nice weekend car just to play around with with my wife. Thank you.
OK I'm leaving the quality of the products out of this, so to the problem. the new engine, I'm guessing you fitted it yourself? So did you put the clutch springs on right, I'm not going to insult you but I think you may have fitted them with the spring tails on the wrong side of the clutch nut so they are perminantly pressing on the inside of the clutch bell. Or there is the possibility that the gear mesh may be too tight between the Bell and Spur gear, either will cause the car to run off as soon as you start it.

The High Idle could be either too lean on the low end, too lean on the high end, Idle screw in too far, feul has too much nitro for the head shimming, AIR LEAKS especially with any pull/roto start engine, fatten up (anticlockwise) the LSN and HSN 1/4 turn and see if that slows the Idle down.

Glad to hear that there is another woman involved in the hobby now too as this was begining to become a complete sausage fest.
Old 10-03-2007, 12:52 AM
  #10  
thopper
Senior Member
 
Join Date: Nov 2004
Location: Fullerton, CA
Posts: 746
Likes: 0
Received 0 Likes on 0 Posts
Default RE: XTM Xterminator help

Drifprojecor-----You may have missed it Hobby People owns Airtronics in the USA as of a month ago. Global Hobby aka Hobby people

does all the repair on Airtronics at this point.....read the fine print these days!
Old 10-03-2007, 03:28 PM
  #11  
DriftProjectR
Senior Member
 
DriftProjectR's Avatar
 
Join Date: Jan 2007
Location: Sin City, NV
Posts: 567
Likes: 0
Received 0 Likes on 0 Posts
Default RE: XTM Xterminator help


ORIGINAL: thopper

Drifprojecor-----You may have missed it Hobby People owns Airtronics in the USA as of a month ago. Global Hobby aka Hobby people

does all the repair on Airtronics at this point.....read the fine print these days!
sorry to say thopper, but incorrect. like i said before, i used to work for hobby people, so don't go saying that i don't know were we get and receive our products from. like i said if you could read.
plus, hobby people/hobby shack/global hobby
just bought the company that is based out of japan. it was bought for revenue, not to take over.
i would know, when the airtronics was bought off by global hobbies, it was the same week all the GM's came to my store to introduce the products. so we were able to ask questions on the buy.

Old 10-03-2007, 05:30 PM
  #12  
thopper
Senior Member
 
Join Date: Nov 2004
Location: Fullerton, CA
Posts: 746
Likes: 0
Received 0 Likes on 0 Posts
Default RE: XTM Xterminator help

Not to beat a dead horse but what are you saying....global hobby is not the owner of the exclusive aitronics distribution in the USA and they dont do the repairs?
They do!
Old 10-04-2007, 09:23 AM
  #13  
DriftProjectR
Senior Member
 
DriftProjectR's Avatar
 
Join Date: Jan 2007
Location: Sin City, NV
Posts: 567
Likes: 0
Received 0 Likes on 0 Posts
Default RE: XTM Xterminator help

ORIGINAL: thopper

Not to beat a dead horse but what are you saying....global hobby is not the owner of the exclusive aitronics distribution in the USA and they dont do the repairs?
They do!
they don't![:'(]
this argument is dead and over, i'm not going to fight with a person who thinks he knows stuff by what he reads in a magazine. yes global hobbies did buy off airtronics, but it was only for revenue (money). its a complete different division of the company. we still send broken/receive products from airtronics, in Glendale, California. not from global hobbies in Fountain Valley, California.

Old 10-04-2007, 01:27 PM
  #14  
thopper
Senior Member
 
Join Date: Nov 2004
Location: Fullerton, CA
Posts: 746
Likes: 0
Received 0 Likes on 0 Posts
Default RE: XTM Xterminator help

You are confused...go to the Airtronics site....

Global Services
Attn: Airtronics
18480 Bandilier Circle
Fountain Valley, CA 92708
TEL: 1-714-963-0329
FAX: 1-714-964-6236

This is off there site!!!!!!!
Old 10-04-2007, 01:34 PM
  #15  
jonnymac
Senior Member
 
Join Date: Jan 2003
Location: leicester, UNITED KINGDOM
Posts: 2,116
Likes: 0
Received 0 Likes on 0 Posts
Default RE: XTM Xterminator help


ORIGINAL: thopper

You are confused...go to the Airtronics site....

Global Services
Attn: Airtronics
18480 Bandilier Circle
Fountain Valley, CA 92708
TEL: 1-714-963-0329
FAX: 1-714-964-6236

This is off there site!!!!!!!
Oooh look he's right you [link=http://www.airtronics.net/Airtronics_Contact.asp]know[/link]
Old 10-04-2007, 03:27 PM
  #16  
Da Smak
Banned
 
Join Date: Feb 2004
Location: North of the, , UNITED KINGDOM
Posts: 6,058
Likes: 0
Received 0 Likes on 0 Posts
Default RE: XTM Xterminator help



Working for Airtronics is like working for McDonalds, you dont have a clue where anything comes from. So LADIES... get B.O.T.


ORIGINAL: Da Smak


ORIGINAL: nobrainedbanana

I am sorry to bog down a forum with a noob question but here goes. My wife and I both bought xtm xterminators and hers worked fine and in typical fashion...min didnt. Had an engine replace and now have the bigger xtm 457engine. Hobby People doesn't like us because we are new and refuse to assist us so they made us break in my engine. Half way through break in...I noticed my car , in a way, locked up. It didnt roll freely....seems the gears dont let it roll. I am not an expert on engines and need any help...should I try another Hobby people. Do they do reairs. Seems to me they hate to be bothered with this. Also.....while I was trying to break it in...the vehicle doesnt run idle....It wants to shoot off as soon as I start it. I turn on the car and radio so it isnt that problem . We both have xtm sure starts in place of the pull starts and when I stick the starter in to crank the vehicle rolls forward as well....if that makes sense. I can get the engine started...but It still rolls high speed as if I gassed it and usually whn i apply the bbrake it stalls but if it doesnt...when I release the brake it is back at running high speed as if I am applying thottle. I have tried everything from changing the idle setting....setting the valves at where they are suppose to be and EVERYTHING....but i am not good at this. I feel frustrated for not knowing what to do even though I have basic knowledge at this and really do not know what to do as my wife has wasted 400+ on this gift for me for my birthday (sept 21). Is the engine messed up? Did I miss something? Is there somewhere I can take this? or is it to late? I enjoyed my car with its first engine and it ran really good...but we got blamed for that engine failing when we didnt do anything to adjust it....when we were told we did move valves. I apologize for the long thread but I really want to have a nice weekend car just to play around with with my wife. Thank you.
OK I'm leaving the quality of the products out of this, so to the problem. the new engine, I'm guessing you fitted it yourself? So did you put the clutch springs on right, I'm not going to insult you but I think you may have fitted them with the spring tails on the wrong side of the clutch nut so they are perminantly pressing on the inside of the clutch bell. Or there is the possibility that the gear mesh may be too tight between the Bell and Spur gear, either will cause the car to run off as soon as you start it.

The High Idle could be either too lean on the low end, too lean on the high end, Idle screw in too far, feul has too much nitro for the head shimming, AIR LEAKS especially with any pull/roto start engine, fatten up (anticlockwise) the LSN and HSN 1/4 turn and see if that slows the Idle down.

Glad to hear that there is another woman involved in the hobby now too as this was begining to become a complete sausage fest.

Old 10-04-2007, 08:35 PM
  #17  
GRANT ED
 
GRANT ED's Avatar
 
Join Date: Apr 2003
Location: Adelaide, AUSTRALIA
Posts: 2,695
Likes: 0
Received 0 Likes on 0 Posts
Default RE: XTM Xterminator help

You have not wasted your money. You just need to set your car up properly, thats all. I own a Rex-x which is the Aussie version of your buggy. There is nothing wrong with them. I have raced mine and beaten a number of so called pro spec cars. As for durability. The only thing I changed was the shock towers to the pro spec verion, thats all. I have not broken anything in the buggy.
Listen to Da Smack with regard to the clutch and tuning issues. Also you could remove the motor and push the car along to see where the binding is.
Keep at it. You'll get it going.
Old 10-05-2007, 12:19 PM
  #18  
rcboy93
Senior Member
 
Join Date: May 2006
Location: simi valley, CA
Posts: 311
Likes: 0
Received 0 Likes on 0 Posts
Default RE: XTM Xterminator help

thank u grant
Old 10-09-2007, 09:39 PM
  #19  
nobrainedbanana
Junior Member
Thread Starter
 
Join Date: Sep 2007
Location: Henderson, NV
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default RE: XTM Xterminator help

Thanks all for the help...I eventually went back to hobby people and had some pointers given to me...but....then after awhile while I was breaking the engine in.....the xtm sure start wouldturn but the piston wouldnt move...so now I have that issue....and as usual...the wifes car still....STILL starts up with no problem. I took apart the sure starter...thought i had it fixed...got it to run again but when my car died out.....once again i as back where I started also i couldnt get the sure starter off the engine it must be loctite...i dunno......... I'm cursed...lol............Thanks for offering help DriftProjectorR.....I might actually need to meet up with u and get some help and pointers.
We didnt actually have a problem with hobby people on Boulder and trop....they seemed helpful....but then again we are VERY new so we dont expect to be treated fair anywhere we go....and I apologize if i seem to be talking bad about them but it was just one of those badfirst experience...bad first impressions to the hobby that made the wife and i think we made a bad mistake......but when she gets her car fired up and she drives it around...it is worth it. But me...i just get excited if i can get it started....lol
But other than that thanks all for the pointers.
Old 10-09-2007, 10:50 PM
  #20  
DriftProjectR
Senior Member
 
DriftProjectR's Avatar
 
Join Date: Jan 2007
Location: Sin City, NV
Posts: 567
Likes: 0
Received 0 Likes on 0 Posts
Default RE: XTM Xterminator help


ORIGINAL: nobrainedbanana

Thanks all for the help...I eventually went back to hobby people and had some pointers given to me...but....then after awhile while I was breaking the engine in.....the xtm sure start wouldturn but the piston wouldnt move...so now I have that issue....and as usual...the wifes car still....STILL starts up with no problem. I took apart the sure starter...thought i had it fixed...got it to run again but when my car died out.....once again i as back where I started also i couldnt get the sure starter off the engine it must be loctite...i dunno......... I'm cursed...lol............Thanks for offering help DriftProjectorR.....I might actually need to meet up with u and get some help and pointers.
We didnt actually have a problem with hobby people on Boulder and trop....they seemed helpful....but then again we are VERY new so we dont expect to be treated fair anywhere we go....and I apologize if i seem to be talking bad about them but it was just one of those badfirst experience...bad first impressions to the hobby that made the wife and i think we made a bad mistake......but when she gets her car fired up and she drives it around...it is worth it. But me...i just get excited if i can get it started....lol
But other than that thanks all for the pointers.
let me know. pm me and ill message you my number.
Old 10-15-2007, 05:10 PM
  #21  
kthatch805
Member
 
Join Date: Jun 2005
Location: T.O., CA
Posts: 54
Likes: 0
Received 0 Likes on 0 Posts
Default RE: XTM Xterminator help

XTM= eXtra Time and Money...but it sounds like ur clutch is engaded and not spinning freely.. therfore when you start it, it takes off on ya... its like starting ur car in gear..... with rc cars the monemtum pushses the clutch to engage the clutch bell.. when its at idle it should be in "neutral"
Old 10-15-2007, 05:36 PM
  #22  
annie_himself
Senior Member
 
annie_himself's Avatar
 
Join Date: Oct 2004
Location: Prairiville, LA
Posts: 6,254
Likes: 0
Received 0 Likes on 0 Posts
Default RE: XTM Xterminator help


ORIGINAL: kthatch805

XTM= eXtra Time and Money...but it sounds like ur clutch is engaded and not spinning freely.. therfore when you start it, it takes off on ya... its like starting ur car in gear..... with rc cars the monemtum pushses the clutch to engage the clutch bell.. when its at idle it should be in "neutral"
Have you ever owned a XTM?
Old 10-15-2007, 05:52 PM
  #23  
kthatch805
Member
 
Join Date: Jun 2005
Location: T.O., CA
Posts: 54
Likes: 0
Received 0 Likes on 0 Posts
Default RE: XTM Xterminator help

sure have.. i owned the X2.... was junk.... and the mammoth... ok but still junk....98% of people will agree with me about XTM it is just not that good of a product....... im sorry to ruin ur day and insult ur rc car but the fact is that they are no Bueno...
Old 10-24-2007, 06:04 AM
  #24  
XT2rules
Junior Member
 
Join Date: Oct 2007
Location: whyalla, AUSTRALIA
Posts: 10
Likes: 0
Received 0 Likes on 0 Posts
Default RE: XTM Xterminator help

hey i agree about people saying their junk and all that. Im should be getting a XT2 for x-mas (2 months) and i dont know what to think some people are saying their crap and some r saying there wicked and good for the money i dont know what to think! all i want it for is racing & bashing what do you think and one more thing how do i start my own forum?
Old 10-24-2007, 01:42 PM
  #25  
Shinji7
Junior Member
 
Shinji7's Avatar
 
Join Date: Sep 2007
Location: Placentia, CA
Posts: 23
Likes: 0
Received 0 Likes on 0 Posts
Default RE: XTM Xterminator help

for bashing they rock! i've crashed mine pretty hard and the only thing i've ever broken was a front arm; i've taken it to the track maybe 3 times and it handeld pretty good, it's a little too heavy now but i'm gonna get another one just for the track...

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.