Go Back  RCU Forums > RC Boats > RC Boats General Discussion
Reload this Page >

Help! New Kyosho Jet Arrow Boat goes slow

Notices
RC Boats General Discussion Discuss general rc boating topics here.

Help! New Kyosho Jet Arrow Boat goes slow

Old 07-29-2014, 03:10 PM
  #1  
ncng
Junior Member
Thread Starter
 
Join Date: Jul 2014
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Default Help! New Kyosho Jet Arrow Boat goes slow

Hello,

Just got my first RC Boat, I put it together, test ran it for 5 minutes and it went fast,
ran great. Next day it started sputtering and I thought it was the loose wire I found
going to motor, but not. Goes slow and just putts around, any ideas?

Older kit, brushed motor, prop is in good order, batteries are good.

Sounds like half speed,

ncng
Old 07-31-2014, 09:28 PM
  #2  
rcguy1411
Senior Member
 
Join Date: Nov 2008
Location: hamilton, ON, CANADA
Posts: 1,444
Likes: 0
Received 0 Likes on 0 Posts
Default

Pull flex shaft and lube it also make shur nothing is binding
Old 08-01-2014, 05:17 PM
  #3  
ncng
Junior Member
Thread Starter
 
Join Date: Jul 2014
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Default

No binding, but seems like motor to shaft coupler is slipping. I was thinking of putting JB Weld on it? Thanks for your help-ncng

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Manage Preferences - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service -

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.