Go Back  RCU Forums > RC Boats > RC Boats General Discussion
Reload this Page >

Boat Newbie Needs Help with a Kyosho Jetstream 800

Notices
RC Boats General Discussion Discuss general rc boating topics here.

Boat Newbie Needs Help with a Kyosho Jetstream 800

Old 10-21-2015, 12:36 PM
  #1  
Trapper_Jon
Junior Member
Thread Starter
 
Join Date: Oct 2015
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Question Boat Newbie Needs Help with a Kyosho Jetstream 800

I was recently given a Kyosho Jet Stream 800 which until a couple of days ago ran great.
Now when I plug in the main battery it immediately starts running in reverse and when I hit the throttle to make it go forward nothing happens. I have changed both the transmitter batteries, the receiver board batteries and tried different main batteries, all yield same result.

Any help would be greatly appreciated as after the batteries I have no clue as to what the problem might be.
Old 10-21-2015, 01:02 PM
  #2  
Hydro Junkie
 
Hydro Junkie's Avatar
 
Join Date: Nov 2004
Location: Marysville, WA
Posts: 10,535
Received 130 Likes on 123 Posts
Default

It sounds like a radio setting issue. If there is someone in your area that runs boats, you might try asking them to help you out

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Manage Preferences - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service -

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.