Notices
RC Car General Discussions This forum is for all general discussions related to radio control cars. Check forums below for more specific categories if applicable.

Traxxas jato 3.3 help please

Old 10-04-2014, 11:35 AM
  #1  
Thread Starter
 
Camo_cowboy84's Avatar
 
Join Date: Oct 2014
Location: Noble, il
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Default Traxxas jato 3.3 help please

I just got a traxxas jato 3.3 and im having an issue it fires up fine its when i take off it bogs a little bit but then takes off like a bat outta hell any suggestions would be greatly appreciated thank you
Old 10-04-2014, 11:41 AM
  #2  
My Feedback: (1)
 
jkdv8's Avatar
 
Join Date: Mar 2004
Location: somewhere
Posts: 945
Likes: 0
Received 0 Likes on 0 Posts
Default

Need to break it in if its new then tune it. If it's used just needs a proper tune and/or new glow plug.
Old 10-04-2014, 11:48 AM
  #3  
Thread Starter
 
Camo_cowboy84's Avatar
 
Join Date: Oct 2014
Location: Noble, il
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Default

Its used ill try a new glow plug and see if i can tune it better thanks
Old 10-04-2014, 12:26 PM
  #4  
My Feedback: (1)
 
jkdv8's Avatar
 
Join Date: Mar 2004
Location: somewhere
Posts: 945
Likes: 0
Received 0 Likes on 0 Posts
Default

No problem.
Old 10-05-2014, 07:01 PM
  #5  
 
1QwkSport2.5r's Avatar
 
Join Date: Oct 2006
Location: Cottage Grove, MN
Posts: 10,420
Received 78 Likes on 71 Posts
Default

If from idle to WOT its doggy at first then winds up and screams (cleans out), the low end is too rich. If you lean it down and it cuts out going from idle to WOT it's too lean. I'd tune it first. If it won't run crisp from idle to WOT, then look to your fuel and glow plug. If the fuel is fresh then replace the glow plug. Usually if a plug is bad, it won't idle for beans and/or it will quit a lot. The element should be silver in color. If it's a silver-gray color you're still in the ballpark. If the element is any other color than silver or silver-gray, it's probably time to replace it. If none of this cures the trouble, check the piston/liner fit. Look brought exhaust port at piston. There should be a shiny band on the side of the piston at the top. If the whole side of the piston is a dull color, the piston fitment is worn out and will need replacement most likely.

Last edited by 1QwkSport2.5r; 10-05-2014 at 07:05 PM. Reason: Fix wording.
Old 10-06-2014, 07:52 AM
  #6  
Thread Starter
 
Camo_cowboy84's Avatar
 
Join Date: Oct 2014
Location: Noble, il
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Default

Thanks quick sport i put a brand new glow plug in and tuned my lsn a little and it takes from dead stop to WOT awesomely thanks again
Old 10-06-2014, 08:40 AM
  #7  
 
1QwkSport2.5r's Avatar
 
Join Date: Oct 2006
Location: Cottage Grove, MN
Posts: 10,420
Received 78 Likes on 71 Posts
Default

As wacky as it sounds, you can tell how your engine is running by "reading" your glow plug. Much like spark plugs in a full size car engine.

Glad you got her running better.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On


Thread Tools
Search this Thread

Contact Us - Manage Preferences Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.