Go Back  RCU Forums > RC Cars, Buggies, Trucks, Tanks and more > RC Car General Discussions
Reload this Page >

Nikko Rhino Aero motor won't stop running

Notices
RC Car General Discussions This forum is for all general discussions related to radio control cars. Check forums below for more specific categories if applicable.

Nikko Rhino Aero motor won't stop running

Old 03-25-2020, 04:22 PM
  #1  
Sam's1967
Junior Member
Thread Starter
 
Join Date: Mar 2020
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default Nikko Rhino Aero motor won't stop running

I have an old Aero Rhino RC buggy with a RS-540SH (6527) Motor. It seemed like it was working fine and then it stopped functioning properly. The engine would not stop, even if I turned the switch off. I recharged the battery and the same thing. I changed the battery on the remote and no change.

The only way I got it to stop was to disconnect the battery. I took it apart and everything seemed to be connected, not loose. Any ideas what the problem may be. I was hoping to give it to my son (I've had the buggy for over 25 years.
Old 03-26-2020, 03:15 AM
  #2  
RustyUs
 
RustyUs's Avatar
 
Join Date: Oct 2012
Location: central PA
Posts: 4,573
Received 5 Likes on 5 Posts
Default

Sounds like the speed control is not finding neutral, and/or transmitter's throttle trim level/knob has gotten bumped.
Old 03-26-2020, 07:35 AM
  #3  
Sam's1967
Junior Member
Thread Starter
 
Join Date: Mar 2020
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default

I think that the motherboard is fried. I wish I could add some pics. Any idea where I may be able to get a motherboard?
Old 03-26-2020, 11:27 PM
  #4  
Big Alice
 
Join Date: Dec 2010
Location: Wenatchee, WA
Posts: 376
Received 1 Like on 1 Post
Default

If by motherboard you mean a circut board in the car with the receiver and speed control on it, you probably have a parts car. Is this the Nikko Rhino Aero RC? buggy

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.