Go Back  RCU Forums > RC Cars, Buggies, Trucks, Tanks and more > RC Car Radio Equipment
Reload this Page >

Problem with 2.4gz radio. PLEASE help

Notices
RC Car Radio Equipment Discuss specific topics related to RC car radios. For general or non rc car specific radio topics please see our regular radio discussion forum.

Problem with 2.4gz radio. PLEASE help

Old 04-16-2012, 03:51 PM
  #1  
dustint209
Junior Member
Thread Starter
 
Join Date: Jun 2007
Location: , LA
Posts: 9
Likes: 0
Received 0 Likes on 0 Posts
Default Problem with 2.4gz radio. PLEASE help

I am having a problem with my remote. It's a HK-GT2 from hobby king. I have binded the radio and receiver with no problem. But When I switch the car on than turn the remote on the steering works fine but the motor does not register. If I pull the trigger slightly the motor beeps to confirm connection than the motor runs at full speed. If I pull the trigger forward the motor stops but as soon as the trigger goes back to center it starts spinning again. I tried to adjust the throttle trim but I cant get it to stop spinning with the trigger in neutral position. I tried with another remote and everything worked fine with no problem. What should I try? Is the radio no more good?
Old 04-16-2012, 04:02 PM
  #2  
itsfishi
Senior Member
 
Join Date: Mar 2005
Location: shellharbour, AUSTRALIA
Posts: 510
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Problem with 2.4gz radio. PLEASE help

try this

i think you may need to set the throttle range

unplug battery to esc turn on transmitter while holding throttle full on plug in battery to esc after beeps return trigger to neutral.switch it all off then back on, see if it works. check your esc manual as you may need to push the trigger out for reverse aswell. im no expert but thats what it sounds like to me. your esc manual will explain.

good luck
Old 09-10-2012, 07:34 PM
  #3  
opwan
My Feedback: (2)
 
Join Date: Sep 2009
Location: Lenoir City, TN
Posts: 151
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Problem with 2.4gz radio. PLEASE help

Re-bind, turn off the ESC and take the bind plug out, see if that works. Oh and reprogram you throttle settings also.


ORIGINAL: dustint209

I am having a problem with my remote. It's a HK-GT2 from hobby king. I have binded the radio and receiver with no problem. But When I switch the car on than turn the remote on the steering works fine but the motor does not register. If I pull the trigger slightly the motor beeps to confirm connection than the motor runs at full speed. If I pull the trigger forward the motor stops but as soon as the trigger goes back to center it starts spinning again. I tried to adjust the throttle trim but I cant get it to stop spinning with the trigger in neutral position. I tried with another remote and everything worked fine with no problem. What should I try? Is the radio no more good?
Old 04-01-2013, 02:32 AM
  #4  
benlinus
Member
 
Join Date: Feb 2013
Location: manchaster, PAKISTAN
Posts: 32
Likes: 0
Received 1 Like on 1 Post
Default RE: Problem with 2.4gz radio. PLEASE help

AGree with itsfishi. You need to set the throttle range, here the way which one you have to use. Firstly you unplug battery to as turn on the transmitter while holding the throttle full on plug in battery for us after beeps return trigger to neutral. switch it all off then back on, see if it works. 

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright © 2022 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.