Notices
RC Car Radio Equipment Discuss specific topics related to RC car radios. For general or non rc car specific radio topics please see our regular radio discussion forum.

losing control randomly

Old 08-28-2004, 04:49 AM
  #1  
Junior Member
Thread Starter
 
Join Date: Aug 2004
Location: , CA
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
Default losing control randomly

My brother recently crashed my X-cellerator, twisted the chassis pretty good and broke a few other parts, including the battery case. I replaced the old battery case with rechargeables, replaced the chassis and a few front end parts, nothing electrical other than the battery change. Now, I have it back together, it starts (with a high idle that i'll have to adjust) and seems to be working properly. I start driving it around and it randomly takes off on its own with no steering or throttle control, but just for a few seconds and then comes back. Any ideas??
Old 08-29-2004, 10:32 AM
  #2  
Banned
My Feedback: (10)
 
Join Date: Jan 2003
Location: manitowoc, WI
Posts: 892
Likes: 0
Received 0 Likes on 0 Posts
Default RE: losing control randomly

If you crashed the battery box I would suppect you need a need rx battery holder.
Old 08-30-2004, 03:57 AM
  #3  
Junior Member
 
Join Date: Mar 2003
Location: dublin, IRELAND
Posts: 29
Likes: 0
Received 0 Likes on 0 Posts
Default RE: losing control randomly

try changing the crystals to a totally different set, maybe that the one in the RX is dodgy.
Old 08-30-2004, 09:54 AM
  #4  
Junior Member
Thread Starter
 
Join Date: Aug 2004
Location: , CA
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
Default RE: losing control randomly

thanks....I went through some trouble shooting this weekend and read up on a few things. It also gets a twitch sometimes, and I read somewhere that the crystals could cause that. I'll give it a shot.
Old 08-31-2004, 07:20 AM
  #5  
Senior Member
 
Join Date: Jan 2004
Location: Melbourne, AUSTRALIA
Posts: 1,070
Likes: 0
Received 0 Likes on 0 Posts
Default RE: losing control randomly

It sounds like a cut in the antenna, in which case the antenna will need replacing.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On


Thread Tools
Search this Thread

Contact Us - Manage Preferences Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.