Go Back  RCU Forums > RC Cars, Buggies, Trucks, Tanks and more > RC Car Radio Equipment
Reload this Page >

Blue Bird hi-Torque Servo Problems...Help!

Notices
RC Car Radio Equipment Discuss specific topics related to RC car radios. For general or non rc car specific radio topics please see our regular radio discussion forum.

Blue Bird hi-Torque Servo Problems...Help!

Old 03-13-2005, 04:34 PM
  #1  
Beau84
Junior Member
Thread Starter
 
Join Date: Jan 2005
Location: QLD, AUSTRALIA
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Default Blue Bird hi-Torque Servo Problems...Help!

I've just bought a Bluebird BMS-620MG Hi-Torque servo to replace the steering servo I got with my MT2. I installed it on my MT2 in that I simply replaced the previous servo which was a Futaba T2ER servo (S2003) which came in a complete handset and servo package.

My problem is now that I have this new servo in, I can definately notice the torque increase but whenever I steer, the throttle glitches and 9 times out of 10 it will steer good for about 30 seconds then it'll glitch and cause the MT2 to become undriveable. It's really annoying me. [:@][:'(]

If anyone could please advise me as to what the problem is it would be greatly apprecited.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Manage Preferences - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service -

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.