Notices
RC Car Radio Equipment Discuss specific topics related to RC car radios. For general or non rc car specific radio topics please see our regular radio discussion forum.

Water in the servo??

Old 04-11-2005, 08:04 AM
  #1  
joffacn
Senior Member
Thread Starter
 
Join Date: Dec 2002
Location: Guangzhou, CHINA
Posts: 107
Likes: 0
Received 0 Likes on 0 Posts
Default Water in the servo??

Hi

The GWS666N steering servo on my Traveller goes full 90 when I turn it on and does not respond to input.

The throttle servo works OK in both channels. My car got wet (splashed) not drowned.

I drove it for a short while afterwards, seemed OK, but the next day when I when to start it just went full deflectionand no response.

I took the cover off the servo and can not see any water droplets. What can I try or is this a replacement job?

Thanks Jeff
Old 04-11-2005, 01:15 PM
  #2  
gerwen
 
gerwen's Avatar
 
Join Date: Nov 2004
Location: St. Thomas, ON, CANADA
Posts: 2,088
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Water in the servo??

Try swapping receiver channels for the servos. Put the steering servo in channel 2 and put the throttle servo in channel 1.
Does the same servo do the same thing or is it the other servo now?
If it is the other servo, then your receiver is the problem.

If it is the same servo, then it is indeed the problem. Pull it completely apart, spray it with WD40, (yes the circuit board, but maybe not the motor) and let it dry for a couple days before putting it back together and trying it out.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Manage Preferences - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service -

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.