Go Back  RCU Forums > RC Cars, Buggies, Trucks, Tanks and more > RC Car Radio Equipment
Reload this Page >

Throttle servo won't work on my buggy?

Notices
RC Car Radio Equipment Discuss specific topics related to RC car radios. For general or non rc car specific radio topics please see our regular radio discussion forum.

Throttle servo won't work on my buggy?

Old 05-01-2005, 10:38 AM
  #1  
snooptalian
Thread Starter
My Feedback: (7)
 
Join Date: Mar 2005
Location: ,, KS
Posts: 327
Likes: 0
Received 0 Likes on 0 Posts
Default Throttle servo won't work on my buggy?

I just got a new XTM X-terminator buggy last week and everything was working perfectly for the first tank I ran thru it, then yesterday while tuning the engine, I gave it some throttle and then all of a sudden I got no throttle response or brake at all, nothing. The steering still works fine, just the throttle stopped doing anything. I checked the plugs to the receiver, batteries, etc, and everything looks good. Has the servo just quit altogether, or is there something else I should check before I try to get this fixed under warranty?

Thanks for the help.
Old 05-02-2005, 08:18 AM
  #2  
gerwen
 
gerwen's Avatar
 
Join Date: Nov 2004
Location: St. Thomas, ON, CANADA
Posts: 2,088
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Throttle servo won't work on my buggy?

You're saying the servo doesn't move when you use the throttle/brake?

Swap the channels on the receiver. Put steering servo on channel 2 and throttle on channel 1.

Which one doesn't work now?
If the throttle servo doesn't move when you turn the wheel, then it's the servo, either internal or lead wire or connector.

If the steering servo doesn't work when you pull the trigger, then it's the radio. Either Tx or Rx.

Let us know so we can go from here.
Old 05-02-2005, 09:38 AM
  #3  
snooptalian
Thread Starter
My Feedback: (7)
 
Join Date: Mar 2005
Location: ,, KS
Posts: 327
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Throttle servo won't work on my buggy?

Thanks for the help...Switched the plugs in the receiver and the throttle servo still doesn't work when putting into the steering slot and moving the steering wheel. So I put a new servo in and everything works now. Hopefully this servo will last more than a day now...

Thanks.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Manage Preferences - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service -

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.