Notices
RC Car Radio Equipment Discuss specific topics related to RC car radios. For general or non rc car specific radio topics please see our regular radio discussion forum.

dead hitec, any fix?

Old 02-09-2008, 10:42 PM
  #1  
j_blaze
Senior Member
Thread Starter
 
j_blaze's Avatar
 
Join Date: Jan 2007
Location: Tampa, FL
Posts: 1,812
Likes: 0
Received 0 Likes on 0 Posts
Default dead hitec, any fix?

ran an hs-5645mg for throttle/brake about 6 tanks so far. got home today and reciever was on, turned it off, no big deal. working on different camber/toe settings i noticed brakes were applied and servo would not back off manually. turned it on and nothing happened. checked reciever and all was good, but no movement. servo won't turn manually and does not warm up if left on. other servos work. toast? problem is racing next 2 weekends and no throttle servo. i have some blue bird backups, but is there any way to fix this? i can sauder (but not spell), or modify anything necessary. i have to mail it in with an rma form, sounds like it will take about 6 months to get it back, any ideas? i may just buy another and wait on the rma unless there is some "secret hitec glitch" that can be fixed very easilly. i tried 2 other servos and new batteries too, no fix.
Old 02-11-2008, 03:28 PM
  #2  
MikeMayberry
Senior Member
My Feedback: (1)
 
MikeMayberry's Avatar
 
Join Date: Jan 2002
Location: Poway, CA
Posts: 3,531
Likes: 0
Received 0 Likes on 0 Posts
Default RE: dead hitec, any fix?

Hitec's turn around time right now is about 5 working days plus shipping. Fill out this form and send it in... no RMA is needed. http://www.hitecrcd.com/Support/service%20form.pdf

Be aware that the digital servos can be very sensitive to the set up in throttle/brake appliations. You really need to make sure you're not overloading the servo at any time... the return spring in many cases can be the problem. The analog 985MG has proven to be very reliable in this application. It typically sells for around $75.

Mike Mayberry
Old 02-11-2008, 11:14 PM
  #3  
j_blaze
Senior Member
Thread Starter
 
j_blaze's Avatar
 
Join Date: Jan 2007
Location: Tampa, FL
Posts: 1,812
Likes: 0
Received 0 Likes on 0 Posts
Default RE: dead hitec, any fix?

if i remember right i had epa set at 60% throttle and 30% brake, i have the same servo in a truggy and it has done wonderfully. i'll keep the 985 in mind as i will have to purchase another servo before the races anyways, maybe the 985 then. many thanks then.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Manage Preferences - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service -

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.