Notices
RC Car Radio Equipment Discuss specific topics related to RC car radios. For general or non rc car specific radio topics please see our regular radio discussion forum.

M11 doesnt retain changes...HELP

Old 03-04-2008, 10:33 PM
  #1  
garabato25
Junior Member
Thread Starter
 
Join Date: Dec 2007
Location: Tampa, FL
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
Default M11 doesnt retain changes...HELP

Hello All,

I have recently purchased an Airtronics M11 radio (2.4). I immediately swapped the batteries for a Lipo and it was working great until this past Sunday.

I had a terrible day of racing due to my cars terrible handling....I changed setting after setting and nothing worked...turns out my EPA were off and of course I found this out after the day was over.....

I eventually started playing with the EPA settings and found that I could change the settings but once I cycled the power on the radio, the EPA settings would return to the previous values (in this case reducing my Left and Right turning radius' from the correct settings desired)

Does anyone know what could cause this problem. The battery is fully charged and I havent made any changes to the settings since I set up my car about 3 weeks ago.

Any help on this matter is greatly appreciated.

Cheers

Alex

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Manage Preferences - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service -

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.