Notices
RC Electric Off-Road Trucks, Buggies, Truggies and more Discuss electric RC off-road, buggies & trucks here. Also discuss brushless motors, speed controllers aka ESC's, brushed motors, etc

Helion Impakt rolls a few feet and stops

Old 05-28-2016, 02:13 PM
  #1  
don60
Junior Member
Thread Starter
 
Join Date: May 2016
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Default Helion Impakt rolls a few feet and stops

Hi all,

I got a Helion Impakt for my 12yr old grandson and the other day he brought it to me with a problem. When the car and controller are turned on the controller trigger causes the car to roll forward or backward about 10 or 15 ft (a few seconds) and stops until the car is turned off and back on then again 10 or 15 ft over and over again. I have:

Put fresh batteries in the controller
Charged the battery in the car
Re-bind on the controller/car
Steering left right continues to work after the car stops rolling.
I have put the car in one place and walked 30-40 feet away, same thing, car rolls a bit, stops, steering still works. (so I don't think the antenna is malfunctioning)
I took the body off the car and unconnected the red/black wire from the ESC to the motor and reconnected.

If you can give me any idea where this problem might be I would like to hear your input. Doesn't really seem like there are too many parts on these things and they are all sealed, but I don't want to just randomly buy replace if I don't have to.

Thanks
Don
Old 05-28-2016, 04:23 PM
  #2  
collector1231
Moderator
My Feedback: (1)
 
collector1231's Avatar
 
Join Date: May 2010
Location: A place in a place.
Posts: 4,192
Likes: 0
Received 0 Likes on 0 Posts
Default

To me, it sounds like a defective radio or receiver. Check the receiver antenna and see if its still connected. Has he been running it for a while, or is it brand new? If you just got it, Helion support should take care of you.

http://helion-rc.com/impakt12B/support.asp
Old 05-28-2016, 04:28 PM
  #3  
don60
Junior Member
Thread Starter
 
Join Date: May 2016
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Default

Thanks for the response. The car is about 3 mos old. I think I'll head back to HobbyTown this time as they are the seller here and see what their opinion is. I like to and can diy stuff but this is uncharted territory for me
Old 05-29-2016, 07:14 AM
  #4  
RustyUs
 
RustyUs's Avatar
 
Join Date: Oct 2012
Location: central PA
Posts: 4,553
Received 3 Likes on 3 Posts
Default

With the "modular" ESC and receiver being an all-in-one package, sorry , that is the part of the RC that I don't like. If the Impakt had a separate speed control and receiver, things would be a lot easier to diagnose and replace.
Old 06-28-2016, 06:42 AM
  #5  
don60
Junior Member
Thread Starter
 
Join Date: May 2016
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Default

For reference it ended up being the charger. Apparently there is a low voltage cutoff and the charger was not getting the battery above that point. New charger fixed😂

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.