Notices
RC Electric Off-Road Trucks, Buggies, Truggies and more Discuss electric RC off-road, buggies & trucks here. Also discuss brushless motors, speed controllers aka ESC's, brushed motors, etc

Fried wires on engine?

Old 02-26-2021, 05:15 AM
  #1  
Blocheren
Junior Member
Thread Starter
 
Join Date: Feb 2021
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Default Fried wires on engine?

What could cause this? (cant post pictures) Its a Tamiya Egress with a LRP GT4 Turbo engine, running 2S 7.4V 5000mAh battery. I just got it and put this battery on it. It ran great until at started to smoke. The wires to the engine started to melt?

Old 02-26-2021, 04:39 PM
  #2  
bill_delong
 
bill_delong's Avatar
 
Join Date: Mar 2009
Location: Austin, TX
Posts: 656
Received 28 Likes on 24 Posts
Default

An engine uses internal combustion powered by fuel... a motor uses electricity powered by a battery

https://www.lrp.cc/en/product/gt4-turbo-12x2/




As far as melting wiring goes, what gauge wire are you using?

Did you check your temps? More info here: What gearing for upgraded electronics?

When was the last time you rebuilt the car? Do you have any seized bearings or binding with the pinion gear removed from the motor?



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.