Notices
RC Electric Off-Road Trucks, Buggies, Truggies and more Discuss electric RC off-road, buggies & trucks here. Also discuss brushless motors, speed controllers aka ESC's, brushed motors, etc

I need Slash Help!

Old 04-04-2009, 08:56 PM
  #1  
iRCHELi
Senior Member
Thread Starter
 
iRCHELi's Avatar
 
Join Date: Feb 2009
Location: Cullman, AL
Posts: 116
Likes: 0
Received 0 Likes on 0 Posts
Default I need Slash Help!

I got a new Titan motor today and Every time I go to run it the Pinion falls off. I get about 5 minutes of run time before it comes unscrewed. I have made sure it was tight every time I did it. Does anyone know why it is doing this?

Thank you for your time,
Kyle
Old 04-04-2009, 09:03 PM
  #2  
samguan
Senior Member
 
Join Date: Sep 2008
Location: Toronto, ON, CANADA
Posts: 1,853
Likes: 0
Received 0 Likes on 0 Posts
Default RE: I need Slash Help!


ORIGINAL: iRCHELi

I got a new Titan motor today and Every time I go to run it the Pinion falls off. I get about 5 minutes of run time before it comes unscrewed. I have made sure it was tight every time I did it. Does anyone know why it is doing this?

Thank you for your time,
Kyle
Make sure you put the screw on the flat surface of the motor shaft.. and make sure you apply a little thread lock and it will never come off itself again.
Old 04-04-2009, 09:16 PM
  #3  
RC_Basher20
Senior Member
My Feedback: (4)
 
RC_Basher20's Avatar
 
Join Date: Dec 2008
Location: North Smithfield, RI
Posts: 122
Likes: 0
Received 0 Likes on 0 Posts
Default RE: I need Slash Help!

if its sliding off the shaft and if its loosening making the shaft spin inside the pinon
add a tiny bit, A TINY BIT! of thread lock
just a very very very very very small amount as in you cant really see it, just feel it on your hand slightly
sometimes they make the grub screw to small or too big (my opinion)
Old 04-04-2009, 09:46 PM
  #4  
d.k.v
Senior Member
 
d.k.v's Avatar
 
Join Date: Aug 2007
Location: perthWA, AUSTRALIA
Posts: 631
Likes: 0
Received 0 Likes on 0 Posts
Default RE: I need Slash Help!

iv had about 40 batts through mine and thats never happened.. how many have you put through yours?
Old 04-04-2009, 10:00 PM
  #5  
iRCHELi
Senior Member
Thread Starter
 
iRCHELi's Avatar
 
Join Date: Feb 2009
Location: Cullman, AL
Posts: 116
Likes: 0
Received 0 Likes on 0 Posts
Default RE: I need Slash Help!

d.k.v,

I got a new motor and I had to take it off of the old one and put it on the new one. When I put it back on I couldn't get it to stay.

Tommorow I am going to try what everyone else suggested.

Kyle
Old 04-05-2009, 12:29 AM
  #6  
FairTax4me
Senior Member
 
FairTax4me's Avatar
 
Join Date: Feb 2008
Location: Charlottesville, VA
Posts: 1,996
Likes: 0
Received 0 Likes on 0 Posts
Default RE: I need Slash Help!

There's a flat on the shaft that is there for the grub screw to seat on so the pinion doesn't slip. You have to make sure the screw is lined up with that when you tighten it down or else it will do exactly what you're describing.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.