Notices
RC Giant Scale Cars For all those who love driving large scale rc cars share your projects or ask questions here.

Kingmotor baja problem

Old 04-22-2013, 08:08 AM
  #1  
kaktus00
Junior Member
Thread Starter
 
Join Date: Apr 2012
Location: , POLAND
Posts: 20
Likes: 0
Received 0 Likes on 0 Posts
Default Kingmotor baja problem

Hi. I have problem wit my km baja:
[youtube]http://www.youtube.com/watch?v=7Jy3Bwbr5iw[/youtube]
How Can i fix these clearances on wheels? I just bought new bearings - it don't help.
Old 04-22-2013, 08:30 AM
  #2  
The Real Dogman
 
The Real Dogman's Avatar
 
Join Date: May 2006
Location: Pontiac, MI
Posts: 2,256
Likes: 0
Received 1 Like on 1 Post
Default RE: Kingmotor baja problem

I did not see clearance issues in your video, I saw wheels that are out of balance. If that's what you are asking about, then by judging the wear on the tires, this car has been run quite abit, which leads me to think that if the tires are just now showing signs of being out of balance, I would tend to think the foams got water or sand in them. That means removing the tires from the rims, clean out all sand and dirt and be sure the foams are dry. If the foams have disintegrated, then you will need to replace the foams.

You will need to remove front tires too

keep us updated of what you find when you remove the tires from the rims.

I hope this helps!!
Old 04-22-2013, 12:42 PM
  #3  
ratpower396
Senior Member
 
ratpower396's Avatar
 
Join Date: May 2004
Location: South river, NJ
Posts: 776
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Kingmotor baja problem

if you are talking about the shake in the suspension arms when you revved the engine that is fairly normal for STOCK suspension parts. You can remove most of the slop with new suspension parts see the following from a baja site http://www.hpibajaforum.com/forum/sh...d.php?t=130602

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.