RCU Forums

RCU Forums (https://www.rcuniverse.com/forum/)
-   RC Giant Scale Cars (https://www.rcuniverse.com/forum/rc-giant-scale-cars-234/)
-   -   Kingmotor baja problem (https://www.rcuniverse.com/forum/rc-giant-scale-cars-234/11487896-kingmotor-baja-problem.html)

kaktus00 04-22-2013 08:08 AM

Kingmotor baja problem
 
Hi. I have problem wit my km baja:
[youtube]http://www.youtube.com/watch?v=7Jy3Bwbr5iw[/youtube]
How Can i fix these clearances on wheels? I just bought new bearings - it don't help.

The Real Dogman 04-22-2013 08:30 AM

RE: Kingmotor baja problem
 
I did not see clearance issues in your video, I saw wheels that are out of balance. If that's what you are asking about, then by judging the wear on the tires, this car has been run quite abit, which leads me to think that if the tires are just now showing signs of being out of balance, I would tend to think the foams got water or sand in them. That means removing the tires from the rims, clean out all sand and dirt and be sure the foams are dry. If the foams have disintegrated, then you will need to replace the foams.

You will need to remove front tires too

keep us updated of what you find when you remove the tires from the rims.

I hope this helps!!<br type="_moz" />

ratpower396 04-22-2013 12:42 PM

RE: Kingmotor baja problem
 
if you are talking about the shake in the suspension arms when you revved the engine that is fairly normal for STOCK suspension parts. You can remove most of the slop with new suspension parts see the following from a baja site http://www.hpibajaforum.com/forum/sh...d.php?t=130602


All times are GMT -8. The time now is 05:36 AM.


Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.