Go Back  RCU Forums > RC Airplanes > RC Jets
Reload this Page >

wren supersport

Notices
RC Jets Discuss RC jets in this forum plus rc turbines and ducted fan power systems

wren supersport

Old 06-09-2010, 12:34 PM
  #1  
new2jets
Senior Member
Thread Starter
 
Join Date: Apr 2008
Location: cheltenham, UNITED KINGDOM
Posts: 111
Likes: 0
Received 0 Likes on 0 Posts
Default wren supersport

trouble again keeps flaming out every time i go to fly i always have trouble of some type[:@]
jason HELP
Old 06-09-2010, 12:42 PM
  #2  
siclick33
 
Join Date: Dec 2003
Location: York, UNITED KINGDOM
Posts: 3,738
Likes: 0
Received 0 Likes on 0 Posts
Default RE: wren supersport

You'll need to give more information for anyone to help.

When does it happen? What does the ECU say as the reason for shutdown? Is there smoke or no smoke during flameout? What batteries/fuel system setup?
Old 06-09-2010, 12:59 PM
  #3  
highhorse
 
highhorse's Avatar
 
Join Date: Nov 2006
Location: Memphis, TN
Posts: 2,289
Likes: 0
Received 0 Likes on 0 Posts
Default RE: wren supersport

have u contacted WREN?
Old 06-09-2010, 01:18 PM
  #4  
new2jets
Senior Member
Thread Starter
 
Join Date: Apr 2008
Location: cheltenham, UNITED KINGDOM
Posts: 111
Likes: 0
Received 0 Likes on 0 Posts
Default RE: wren supersport


ORIGINAL: highhorse

have u contacted WREN?
Not yet this time , yep loads of smoke been having trouble throttling up, put acceleration delay up to 36 helps but still no joy .
I ll get info from ecu and post it . it would be intresting what settings other people are useing on there ecu. does hot weather affect it ? not that its that hot in the uk[&o]
Old 06-09-2010, 01:34 PM
  #5  
bluescoobydoo
 
Join Date: Dec 2006
Location: harwich, UNITED KINGDOM
Posts: 709
Likes: 0
Received 0 Likes on 0 Posts
Default RE: wren supersport

i have a 54 and the only reason it has ever flamed out is that i brought a cheap uat and it was letting air in make sure you have no bubbles in you fuel supply
Old 06-09-2010, 01:42 PM
  #6  
David Gladwin
 
David Gladwin's Avatar
 
Join Date: Feb 2002
Location: CookhamBerkshire, UNITED KINGDOM
Posts: 3,664
Received 29 Likes on 20 Posts
Default RE: wren supersport

Just curious BUT you are having problems with a Wren engine so why not talk to Wren directly ? They are in the UK and have first class customer service which is only a phone call away !

David G.
Old 06-09-2010, 01:47 PM
  #7  
Colin_Mc
 
Colin_Mc's Avatar
 
Join Date: Feb 2006
Location: Dumbarton, scotland
Posts: 201
Likes: 0
Received 0 Likes on 0 Posts
Default RE: wren supersport

I have/had the same problem - is it the flightworks pump you have? If so try increasing the decel delay to 40 as I found when coming down from say full chat the rpm would drop below 28k and it would cut as the pump/ecu didn't have time to catch it. What I think is the problem is that since the pump is brushed it will need bedding in/freeing up so i plan on flying it for a while just being aware that its slightly slower to come down from thrust.

For note, in my efforts to find the problem I took the whole fuel system apart and even ran it direct from a bvm hopper tank which made 0 difference. Also, I am running 6mm festo tubing from a kevlar fuel cell so the pump has no issues pulling the fuel in and certainly no air bubbles observed!

Cheers,

Colin
Old 06-09-2010, 02:00 PM
  #8  
siclick33
 
Join Date: Dec 2003
Location: York, UNITED KINGDOM
Posts: 3,738
Likes: 0
Received 0 Likes on 0 Posts
Default RE: wren supersport

That doesn't sound like the same problem to me. One is an accel problem and the other a decel.

My supersport is packed away at the moment but I've just checked my kit built Mk3 and the accel delay is set at 17. My guess would be air in the fuel. What is your fuel tank setup?
Old 06-09-2010, 02:06 PM
  #9  
ron Sweeney
 
Join Date: Mar 2006
Location: West KirbyWirral, UNITED KINGDOM
Posts: 545
Likes: 0
Received 0 Likes on 0 Posts
Default RE: wren supersport

Without wishing to be critical there may be an installation problem. Has the turbine run successfully in the currennt model? I have 42 hours on my SS and it runs on standard 3mm fuel tubing as originally supplied fed from a BVM air trap. It has occassionally flamed out but the reason has always been a consequence of an external problem. As Dave says Wren can't be more helpful. Ron.
Old 06-09-2010, 04:28 PM
  #10  
new2jets
Senior Member
Thread Starter
 
Join Date: Apr 2008
Location: cheltenham, UNITED KINGDOM
Posts: 111
Likes: 0
Received 0 Likes on 0 Posts
Default RE: wren supersport

ORIGINAL: ron Sweeney

Without wishing to be critical there may be an installation problem. Has the turbine run successfully in the currennt model? I have 42 hours on my SS and it runs on standard 3mm fuel tubing as originally supplied fed from a BVM air trap. It has occassionally flamed out but the reason has always been a consequence of an external problem. As Dave says Wren can't be more helpful. Ron.
over 100 flights so not looking at set up and no air in fuel line, seems to be over fueling on throttling up thats why i put delay up to 36 from 15 , but now seems to have proper flame out with loads of smoke ,before was a big blue flame out the back not good. wondering if pump has losened up but have recalibrated throttle ,[&o]
Old 06-09-2010, 04:36 PM
  #11  
siclick33
 
Join Date: Dec 2003
Location: York, UNITED KINGDOM
Posts: 3,738
Likes: 0
Received 0 Likes on 0 Posts
Default RE: wren supersport

I assume you're using on board fuel filters? I would check/clean/replace them and see if that makes any difference.
Old 06-09-2010, 04:43 PM
  #12  
new2jets
Senior Member
Thread Starter
 
Join Date: Apr 2008
Location: cheltenham, UNITED KINGDOM
Posts: 111
Likes: 0
Received 0 Likes on 0 Posts
Default RE: wren supersport

had a lot of trouble at merrryfield but put it down to the heat how wrong i was[&o]
Old 06-09-2010, 05:25 PM
  #13  
jason
My Feedback: (1)
 
jason's Avatar
 
Join Date: Jan 2002
Location: kenilworth , UNITED KINGDOM
Posts: 2,354
Received 0 Likes on 0 Posts
Default RE: wren supersport

From the discription it sounds like you have a blocked needle or two or more likely some worn out sticks. I guess it could also be the pump so I'd try another and if that don't sort it then send it off to Wren.

Be sure to let us know when it's sorted.

Jason
Old 06-09-2010, 11:42 PM
  #14  
joeflyer
My Feedback: (47)
 
Join Date: Dec 2001
Location: Plymouth, MI
Posts: 2,870
Likes: 0
Received 5 Likes on 5 Posts
Default RE: wren supersport

Check to see if one of the tailcone screws are missing. If so replace it using Locktite and it will be back to normal. It happened to mine and to a friends.

Joe
Old 06-10-2010, 05:27 AM
  #15  
ron Sweeney
 
Join Date: Mar 2006
Location: West KirbyWirral, UNITED KINGDOM
Posts: 545
Likes: 0
Received 0 Likes on 0 Posts
Default RE: wren supersport

Whatever it is I am keen to kow the outcome, keep us informed, Ron.
Old 06-10-2010, 05:29 AM
  #16  
Boomerang1
 
Boomerang1's Avatar
 
Join Date: Jun 2005
Location: Sydney, AUSTRALIA
Posts: 2,897
Received 2 Likes on 1 Post
Default RE: wren supersport

I had exactly the same problem with a 44, screws fell out of the back of the engine. Probably the easiest thing to diagnose! - John.
Old 06-10-2010, 05:31 AM
  #17  
ron Sweeney
 
Join Date: Mar 2006
Location: West KirbyWirral, UNITED KINGDOM
Posts: 545
Likes: 0
Received 0 Likes on 0 Posts
Default RE: wren supersport

Another thought, have you a pal with an SS who would lend you his ecu. One of my freinds was having trouble with his SS with a new ecu which gave some very erratic behaviour. When we sustituted my ecu the turbine ran perfectly proving the ecu was at fault. Ron.
Old 06-10-2010, 05:55 AM
  #18  
HarryC
My Feedback: (1)
 
Join Date: Feb 2002
Location: private, UNITED KINGDOM
Posts: 3,647
Likes: 0
Received 11 Likes on 7 Posts
Default RE: wren supersport

Presumably you have spoken to Wren to let them solve it?
Old 06-10-2010, 06:35 AM
  #19  
geh3
My Feedback: (84)
 
geh3's Avatar
 
Join Date: Oct 2003
Location: wilmington, DE
Posts: 1,367
Likes: 0
Received 0 Likes on 0 Posts
Default RE: wren supersport

I have had botha MW-54 and a SS. both were perfect turbines, no trouble of any kind, super smooth operation. How far are you from here>>>Unit 19, Century Park Network Centre,
Manvers
Rotherham
S63 5DE
UK
OR even easier call here>>>Telephone: +44 (0) 1709 877439
These guys have the best backup service ever!!! they can probably get you back in the air in a day or 2!!!!!!!!!!
Old 06-10-2010, 11:21 AM
  #20  
box55555
 
box55555's Avatar
 
Join Date: Oct 2006
Location: cheltenhamgloucestershire, UNITED KINGDOM
Posts: 30
Likes: 0
Received 0 Likes on 0 Posts
Default RE: wren supersport

Hi All

I have had 18 successful flights with no problems at all. At Merryfield my SS overfueled on vealously applying full throttle and shut itself down.

increased the acceleration delay from 15 to 20 and had two more successfull flights. Last weekend had two more overfueled escapades and was lucky to get away with the dead sticks. Accel now up to 35. If you accelerate to quickly from idle you get that funny roaring noise just before the ECU shuts the turbine down.

I too will be speaking to Wren.
Old 06-10-2010, 01:34 PM
  #21  
HarryC
My Feedback: (1)
 
Join Date: Feb 2002
Location: private, UNITED KINGDOM
Posts: 3,647
Likes: 0
Received 11 Likes on 7 Posts
Default RE: wren supersport

Is there some sort of Bermuda Triangle around Cheltenham that affects Wren ECUs? new2jets and box5555 both have same problem, both from same town? At Merryfield I couldn't fly because the new ECU with my Wren 160 would not work. I live in....... Cheltenham!
Old 06-10-2010, 04:41 PM
  #22  
new2jets
Senior Member
Thread Starter
 
Join Date: Apr 2008
Location: cheltenham, UNITED KINGDOM
Posts: 111
Likes: 0
Received 0 Likes on 0 Posts
Default RE: wren supersport

Just went and looked no screws missing that just seem to easy!
harry ,roger, me and now rob all live in cheltenham all with maybe ecu problems! scarey there won`t be a ecu to borrow.
looks like i will be speaking to wren too[&o]
box55555 and i fly together and our turbin problems are much the same on the same days bermuda triangle sounds like it
Old 06-10-2010, 04:55 PM
  #23  
HarryC
My Feedback: (1)
 
Join Date: Feb 2002
Location: private, UNITED KINGDOM
Posts: 3,647
Likes: 0
Received 11 Likes on 7 Posts
Default RE: wren supersport

Fortunately both my Super Sport's ECUs are working fine.
Oh no, that's put the kiss of death on it.....!
Old 06-11-2010, 03:16 AM
  #24  
ron Sweeney
 
Join Date: Mar 2006
Location: West KirbyWirral, UNITED KINGDOM
Posts: 545
Likes: 0
Received 0 Likes on 0 Posts
Default RE: wren supersport

Hi Harry. the pal of mine who experienced ecu trouble was on his second one, the first had proved faulty and Wren had changed it. Not saying that this is your problem. Ron
Old 06-13-2010, 10:30 AM
  #25  
box55555
 
box55555's Avatar
 
Join Date: Oct 2006
Location: cheltenhamgloucestershire, UNITED KINGDOM
Posts: 30
Likes: 0
Received 0 Likes on 0 Posts
Default RE: wren supersport

Hi new2jets
Sorry but we have all been waffling, but have not answered your original question.

My engine ECU setting
Idle 43,000
Stop 28,000
Accel delay 015 (original) now increased to 030 (to stop the problem)
Decel delay 010
Stability 050
Pump start Auto +1
Pump ramp 006

Have contacted Wren with these values and they have requested more info

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.