RCU Forums

RCU Forums (https://www.rcuniverse.com/forum/)
-   RC Jets (https://www.rcuniverse.com/forum/rc-jets-120/)
-   -   A little bug for me with the latest Futaba 18mz software update. 2.5.1 Anyone else? (https://www.rcuniverse.com/forum/rc-jets-120/11611765-little-bug-me-latest-futaba-18mz-software-update-2-5-1-anyone-else.html)

stevekott 01-09-2015 07:28 PM

A little bug for me with the latest Futaba 18mz software update. 2.5.1 Anyone else?
 
Ok so last weekend I updated my 18mz to the latest 2.5.1

I also coincidentally had one of my CB-Elektronics FSS-460 Pitot Airspeed sensors start acting up.

It was zeroing out at 32 mph on start up and seemed like the air speeds were erroneously high.

So I swapped it out with one I had in another model ... same problem.

I went back to software 2.4.1 and it seemed to fix the problem. I will go flying tomorrow and see how it behaves in the air.

I was wondering if anyone else has updated and had any issues. Thanks!

MorseAircraftDevelopment 01-09-2015 11:31 PM

I have updated 5 of them and we have not seen any issues yet on the telemetry side of things, but we are not running the sensor you are speaking of. We are running info directly off our FADEC so we don't need our handheld units for normal operations and then running different sensors for our airspeed (ASSI) and then our normal GPS from Futaba and voltage info from the PowerBox Royals. I do have a fellow pilot that has that system, we will see if we get the same results. But if you reverted back to the last update and that fixed it you will probably need to contact Futaba about that one. I'm pretty good with the Futaba systems ( I set up almost all of the ones in our club) but that one sounds like something that only they could answer... Maybe.

Carsten Groen 01-10-2015 12:16 AM

Steve,
I also see problems with the new firmware. I modified my ASSI device to use the "True airspeed" sensor type they added.
The values will not update on the "telemetry screen", I have to add the sensor to the "home 2" screen, then they will update. They also update if I press on the actual sensor on the "telemetry screen", otherwise not.
And then I can not understand why they did the JetCat sensor the way they did, using 14(!) slots for the data, and you can not disable those that you do not want to see !!
I don't care about many of the parameters, but they have to throw them all in my face :(
Again the "non-flexibility" of the telemetry shows its face.....

MorseAircraftDevelopment 01-10-2015 12:25 AM

I would have to agree with Carsten. Futaba really needs to do some things with the telemetry for jet guys. I have been hardcore Futaba for years and have owned every top end radio, I hope they can fix these issues. Not all of us use JetCat. But with the Xicoy interface for the FADEC unit that doesn't really come into play. But, my readings are all in degrees, no user defined ability to change the degrees into what we need them to say. And then with PowerBox Royals, those guys have got everything lined up for us to get the gps data from the unit but Futaba is the one that needs to let us read the data. I will have to say, they are not leading the pack in the telemetry field, which sucks because I really like the 18MZ, and Futaba products.

Carsten Groen 01-10-2015 12:30 AM

Totally agree!
And there is no support for dual engine systems whether jetcat or other engine types.
Glad I have my Android telemetry system ;)

Springbok Flyer 01-10-2015 03:20 AM


Originally Posted by Carsten Groen (Post 11958369)
Glad I have my Android telemetry system ;)

Carsten,

Talking of which, how are you going with the AMT interface?

Cheers,

Jan

Carsten Groen 01-10-2015 03:41 AM

Hi Jan,
(red ears here :D) I have been overwhelmed with work but the nice test system from AMT is on my desk starting monday evening :)
I'll get back once I have the stuff decoded

TJPro351 01-10-2015 04:26 AM

I have the PowerBox GPS II sensor and also reading 32 mph on my GPS speed. I read it as soon as I power on the radio. Today, I will power up GPS on the jet and when I receive a good GPS signal, will check it again. I may try to reset sensor and if that doesn't work, go back to 2.4.1

dvcam99 01-10-2015 08:54 AM


Originally Posted by TJPro351 (Post 11958412)
I have the PowerBox GPS II sensor and also reading 32 mph on my GPS speed. I read it as soon as I power on the radio. Today, I will power up GPS on the jet and when I receive a good GPS signal, will check it again. I may try to reset sensor and if that doesn't work, go back to 2.4.1


Hi guys,

try out for testing "Metric" instead of "Yard-Pound" in the SYSTEM UNIT menu.
See if you can observe more logical results.


BR
Dirk

stevekott 01-10-2015 09:25 AM


Originally Posted by TJPro351 (Post 11958412)
I have the PowerBox GPS II sensor and also reading 32 mph on my GPS speed. I read it as soon as I power on the radio. Today, I will power up GPS on the jet and when I receive a good GPS signal, will check it again. I may try to reset sensor and if that doesn't work, go back to 2.4.1

Sounds like the same bug with a different sensor.

The fact that it reads 32 instead of 0 makes it seem like its some sort of unit of measure conversion bug. 32 degrees Farenheit = 0 degrees Celsius. I know its a speed measurement, not temperature but it seems like more than coincidence.

And I'm with the rest of you. Come on Futaba! If you want to stay the leader you have to lead! Love my 18mz best radio in my book but some of the 'others' are making quick progress on the telemetry front.

TJPro351 01-10-2015 10:12 AM


Originally Posted by dvcam99 (Post 11958511)
Hi guys,

try out for testing "Metric" instead of "Yard-Pound" in the SYSTEM UNIT menu.
See if you can observe more logical results.


BR
Dirk

When I select Meters, speed indicates correctly (0 KM/H). In yards- pound mode, I also had set a maximum speed threshold of 160 mph (Type 4 alert) and that speed indicated 518mph when I switched it back to Yards-Pound. I attempted to reset it and I could only get to 124 mph. I had to arrow down to 0 and set it back to 160 mph. Obviously there is a conversion issue. Think I will go back to 2,4,1

MorseAircraftDevelopment 01-10-2015 12:06 PM

Now that I think of it, I had to do the same thing, I had to go back to Metric, seems fuatba "0" is converted to 32 F. Seems they use metric a the "0" point. I totally missed that you were using the yard pound system instead of the metric system. All of this leads to the point that we cant put things in to speed reading instead of a temperature reading for our telemetry sensors. I did get the same results as you in the Yard pound system.

TJPro351 01-10-2015 12:48 PM

Can anyone send me version 2.4.1 or on where to download from....stupid me deleted in on SD card :( From now on, I will keep all updates on my computer hard drive for cases like this....lesson learned!!
Seems futaba website only saves previous software update pdf files.

MorseAircraftDevelopment 01-10-2015 12:52 PM

sent you a PM, I have it

gotspg 01-10-2015 06:19 PM

I noticed the same 32mph GPS malfunction last weekend after updating to the latest software. I spoke to Futaba support on Monday and again yesterday. It's a bug with the new software update, don't know when they will have a fix but they know about the issue and are working on it.

stevekott 01-10-2015 09:16 PM


Originally Posted by gotspg (Post 11958800)
I noticed the same 32mph GPS malfunction last weekend after updating to the latest software. I spoke to Futaba support on Monday and again yesterday. It's a bug with the new software update, don't know when they will have a fix but they know about the issue and are working on it.

Which Sensor gave you that problem?

gotspg 01-11-2015 05:41 AM

I'm using the Futaba SPS 01G sensor. I tryied a new receiver, new sensor, new model, re-updating the software, etc. When I spoke to Futaba the first time, the guy had a freshly updated 18mz, he tried it and it was doing the same thing as mine.

afterburner 01-11-2015 09:10 AM

In my opinion, Futaba is really dropping the ball on their $3K flagship transmitter. Updates are far and few between and most are little tweaks. You can request new features in the Futaba support forum where the mod sends them directly to Futaba. I've put in a few and although some may be jet related, others seemed to be universal like a talking timer. How many flyers would find that useful? Having been a Futaba user since day one, I would still recommend them to a newbie but if someone asked me today what brand of flagship radio they should buy, it would not be this radio specifically because either Futaba doesn't want to add new useful features or more than likely they didn't put that flexibility into it when it was in the design stage. Right now you can buy a Jeti 16 which seems to have way more useful features and telemetry for almost half the price of an 18 and have enough leftover to change out a good number of planes to Jeti Rx's. I really like the 18 but thought it was overpriced when I bought it a few years ago but now with the competition out there it is really not worth it. I hope Futaba can change my mind but I'm not holding my breath.

MorseAircraftDevelopment 01-11-2015 09:51 AM

' I hope Futaba can change my mind but I'm not holding my breath.'

I'm right there with you afterburner.

JustJets 01-12-2015 06:16 PM

Ok so the new update has a coding issue when in the US mode. Mine only working correctly when set to Metric. Any word from Futaba on a correction to the last update?

Anyone spoke directly to Futaba ?

gotspg 04-02-2015 03:28 PM

Come on Futaba, can we get a bug fix or something?

DrScoles 04-02-2015 08:56 PM

I can't even get the 2.5 to install. says "update not compatible with this transmitter" anyone have any ideas on how I can get it to work. Guessing I am doing something wrong when I transfer the files off my pc, but this isn't rocket science... lol

mick15 04-03-2015 12:52 AM

I have a similar problem, mine says "Files not found" don't think I'll bother.

m

SpiderJets 07-28-2015 09:26 AM

I am sure everyone has figured it out already... You need to use an empty SD-card, not forget to unzip the downloaded zip file properly, and above all do this download and unzipping with a WINDOWS computer (it does not unzip them all correctly on a Mac, resulting in the "not compatible" message... ask me how I know.... I lost today one hour on this). Note it is not 100% clear that the files are/were unzipped indeed

I am quite worried about the short note that for European transmitters in version V2.5.0 the transmission seems to be restricted to 100 mW. Some of my planes are all carbon fibre and I did not have any issues so far...

Is it worth it to upgrade to V2.5.0 or should I go back to V2.4.1 too ?

FenderBean 07-28-2015 09:41 AM

I dont suppose anyone knows if they fixed the issue with GPS sensors not working after the last update? Im still running an older version so I dont run into this with my Robbe gps sensor


All times are GMT -8. The time now is 05:42 PM.


Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.