Notices
RC Monster Trucks Discuss rc monster trucks in this forum

Stampede Clutch Problems

Old 06-26-2009, 01:11 PM
  #1  
TheCrunge
Senior Member
Thread Starter
 
TheCrunge's Avatar
 
Join Date: Mar 2009
Location: West Milford, NJ
Posts: 112
Likes: 0
Received 0 Likes on 0 Posts
Default Stampede Clutch Problems

Hello all, I am having an annoying problem with my Stampede. While running it yesterday, the clutch started slipping. It has done this before and after tightening the slipper clutch, things are usually fine. However after tightening the clutch last night, it stopped slipping but isn't transferring any power. After tightening and loosening the clutch several times now, the truck barely moves. I can't even get the clutch to slip anymore, it just seems to be geared down really low. I have read about how to tune the clutch but nothing seems to be helping. I took the washers and spur off, but everything else seems alright. Is there something I need to be looking for? Is it something actually inside the transmission? Thanks in advance for your help.
Old 06-26-2009, 04:18 PM
  #2  
nitromandh
Senior Member
 
nitromandh's Avatar
 
Join Date: Aug 2008
Location: Florence, KY
Posts: 120
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Stampede Clutch Problems

Is it the nitro stampede or the electric one?
Old 06-26-2009, 04:32 PM
  #3  
Chris_RC
Senior Member
 
Chris_RC's Avatar
 
Join Date: Nov 2005
Location: Southern California, CA
Posts: 6,912
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Stampede Clutch Problems


ORIGINAL: rckid902

Is it the nitro stampede or the electric one?
The clutch is slipping, of course it is nitro.
Old 06-26-2009, 04:59 PM
  #4  
TheCrunge
Senior Member
Thread Starter
 
TheCrunge's Avatar
 
Join Date: Mar 2009
Location: West Milford, NJ
Posts: 112
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Stampede Clutch Problems

Maybe my original post was misphrased because it is an electric truck.

My problem is either with my slipper clutch or transmission. I have had the slipper clutch apart and besides a missing friction peg and the rest of them being worn, it looks alright.

I have a feeling the problem is the tranny. I have it almost apart, but need an allen to take the grub screw off the pinion. Does anyone know what size allen this is? Is there anything specific to look for that could easily break in the tranny?
Old 06-26-2009, 06:38 PM
  #5  
The_Collector
Senior Member
 
The_Collector's Avatar
 
Join Date: Jul 2005
Location: Reading, PA
Posts: 1,381
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Stampede Clutch Problems

2mm or 2.5mm for those allen screws. Can't remember exactly.
Old 06-26-2009, 06:40 PM
  #6  
nitromandh
Senior Member
 
nitromandh's Avatar
 
Join Date: Aug 2008
Location: Florence, KY
Posts: 120
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Stampede Clutch Problems

My guess it is the tranny too. And sorry I don't know the size.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.