Notices
RC Radios, Transmitters, Receivers, Servos, gyros Discussion all about rc radios, transmitters, receivers, servos, etc.

Hitec HS 5645-MG servo that's acking weird.

Old 05-21-2011, 01:27 AM
  #1  
scooterinvegas
Senior Member
Thread Starter
My Feedback: (1)
 
scooterinvegas's Avatar
 
Join Date: Mar 2010
Location: Las Vegas, NV
Posts: 1,278
Likes: 0
Received 0 Likes on 0 Posts
Default Hitec HS 5645-MG servo that's acking weird.

HS 5645MG is not going all the way forward. It seams to move about 60-70% then stops. And it re-centers it's self with the push rod hooked up to the flap. But if I unhook the push rod, it sticks. If I lighty pull the arm, it's will center. It doesn't take much presure, just a little. Could it be a bad gear set, or something on the endside?
Old 05-21-2011, 04:37 AM
  #2  
allans
My Feedback: (11)
 
Join Date: Nov 2002
Location: Yorktown Hgts, NY
Posts: 266
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Hitec HS 5645-MG servo that's acking weird.

Send it back to hitec.
Old 05-21-2011, 09:34 AM
  #3  
scooterinvegas
Senior Member
Thread Starter
My Feedback: (1)
 
scooterinvegas's Avatar
 
Join Date: Mar 2010
Location: Las Vegas, NV
Posts: 1,278
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Hitec HS 5645-MG servo that's acking weird.

Does anyone know why it would be doing that/this?

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.