Notices
RC Radios, Transmitters, Receivers, Servos, gyros Discussion all about rc radios, transmitters, receivers, servos, etc.

Can't get retractable gear to work with TTX650

Old 01-31-2022, 02:57 PM
  #1  
cracker39
Thread Starter
 
cracker39's Avatar
 
Join Date: May 2007
Location: Lake Alfred, FL
Posts: 144
Likes: 0
Received 0 Likes on 0 Posts
Default Can't get retractable gear to work with TTX650

Hi, I am an 83 year old RC pilot with limited experience. About 7 years ago a friend gave me a nearly new Tactic TTX650 transmitter and a flyable Critical Mass foam plane that I havenít flown yet. I have used the TX on a couple of my planes but using only 4 channels and no switches. I have a problem programming retractable landing gear and I have read and tried everything in the manual. I am pretty sure that the retractable landing gear worked on the plane when I got it. Now, the gear is down and I canít make it move. I have programmed switch A for channel 5 (as the connectors are labeled) for the gear, and switch D for the speed brakes (flaps). The speed brakes work, but the gear does not. I have used three different Y connectors, plugged just one connector into the RX, and used two different TR624 receivers. I have connected a 11.1 v lipo battery to an ESC, and the ESC to the receiver channel 3. The speed flaps are on channel 6 and the gear on channel 5. I know this is may not be enough info, so if you need specifics, please ask. I want to fly this plane, which I can do with the gear down, but I would really like to see the gear retract while flying. Thanks.
Old 01-31-2022, 05:27 PM
  #2  
mongo
My Feedback: (15)
 
mongo's Avatar
 
Join Date: Dec 2001
Location: Midland, TX
Posts: 3,257
Received 58 Likes on 50 Posts
Default

just as a check, plug the speed brakes in to ch 5 and the retracts into ch 6, and verify that the retracts do work and the the tx is sending a signal to ch 5
Old 01-31-2022, 07:20 PM
  #3  
cracker39
Thread Starter
 
cracker39's Avatar
 
Join Date: May 2007
Location: Lake Alfred, FL
Posts: 144
Likes: 0
Received 0 Likes on 0 Posts
Default

I am pretty sure Idid that, but I tried again. When the speed brakes are plugged into 5 and 6 they work. When the retracts are plugged into 5 and 6 they do not work. I find it hard to believe that both retracts would fail with no useage. This has me stumped. Tomorrow I will look for my servo tester and use it to see if the retracts will work.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell or Share My Personal Information -

Copyright © 2023 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.