Notices
RC Radios, Transmitters, Receivers, Servos, gyros Discussion all about rc radios, transmitters, receivers, servos, etc.

What's happening????

Old 12-21-2005, 08:41 PM
  #1  
mackey1
Senior Member
Thread Starter
My Feedback: (24)
 
Join Date: Feb 2002
Location: Gladstone, MO
Posts: 184
Likes: 0
Received 0 Likes on 0 Posts
Default What's happening????

Hi,
Took my foamy out today for its first flight with new Hacker brushless motor. Range checked OK, motor ran fine but.............I hand launched it level, it flew level about 100', pitched down, I caught it, it pitched up, I caught it, it rolled inverted...etc. It did more tricks in 1 minute than I know how to do! I was never able to get it stabilized so that I could evaluate trim etc. Fought it all the way just to get it back over field with about 15 mph wind. I went to full off on throttle and it seemed better but it would still pitch down suddenly.

I've flown this A/C before with a different motor and it flew fine, except it started this nonsense with that motor also. I use the same xmitter on 4 other models without problems. My guess is its either the receiver is bad or the components, ESC, RCV, Servos are too close together.

Looking for ideas! I struggled through 4 flights today. Why I ever to it up after the first flight but I did. HELP!
Old 12-21-2005, 09:32 PM
  #2  
ghendrix01
Senior Member
My Feedback: (1)
 
ghendrix01's Avatar
 
Join Date: Feb 2002
Location: Florissant, MO,
Posts: 302
Likes: 0
Received 0 Likes on 0 Posts
Default RE: What's happening????

A couple of suggestions:

1. If the receiver has been thru a crash, have it checked or at least change the crystal.
2. Check the balance of the plane. It may sound wrong but tucking the nose at lower throttle positions may indicate tail heavy since going full throttle helped.

I would lean to number 1, unless no crash is involved.


good luck,

George

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.