RCU Forums

RCU Forums (https://www.rcuniverse.com/forum/)
-   RC Radios, Transmitters, Receivers, Servos, gyros (https://www.rcuniverse.com/forum/rc-radios-transmitters-receivers-servos-gyros-157/)
-   -   eratic servo control (https://www.rcuniverse.com/forum/rc-radios-transmitters-receivers-servos-gyros-157/10657849-eratic-servo-control.html)

pn 08-06-2011 02:45 AM

eratic servo control
 
hi
can anybody help please . iam having problems with my 40Mhz system every now and then all servos go ape .
receiver runs on bec from power controler, and the boat carries a 2.4Ghz tx all leads have ferrite beads on them ?
the receiver is fatuba 7channel the hand set is also used with another unit with no problem!.
it does not seem to be arange problem usualy as its usaly 5-25 yards when problems start?
rarely at great range some times 600yards with no probs.
any ideas please

BuschBarber 08-06-2011 03:02 AM

RE: eratic servo control
 


ORIGINAL: pn

hi
can anybody help please . iam having problems with my 40Mhz system every now and then all servos go ape .
receiver runs on bec from power controler, and the boat carries a 2.4Ghz tx all leads have ferrite beads on them ?
the receiver is fatuba 7channel the hand set is also used with another unit with no problem!.
it does not seem to be arange problem usualy as its usaly 5-25 yards when problems start?
rarely at great range some times 600yards with no probs.
any ideas please
This is a little confusing. You state you have a 40Mhz radio with a 2.4Ghz Tx. What model Tx and Rx do you have? What exactly is the Power Controller (do you mean ESC?)? What type and voltage of batteries are you using? How is the antenna routed?

pn 08-06-2011 08:14 AM

RE: eratic servo control
 
hi rich
thanks for your reply, the boat is controled by a fatuba 40Mhz hand set .
but carries on board a 2.4Ghz Tx for video link. i have tried with 2.4Ghz Tx turned off but with no visable difference
thanks.

Rodney 08-06-2011 09:51 AM

RE: eratic servo control
 
If you still have problems with the on board telemetry off, you most probably have some bad connection between the receiver and servos or between the battery and receiver. Check all your connectors for corrosion (a common problem with boats especially if used on other than very pure * no salt* water).

pn 08-10-2011 11:58 AM

RE: eratic servo control
 
hi
thanks for your reply
i have checked all the reachable connecters! the receiver power comes from a battery elimanater circuit in the motor controler.
the main power being 12vdc the 5vdc seems ok when tested static on shore, i have fitted ferrite beads round most of the cables no change,the servos work ok on tester, if its the receiver you would have expected it to happen more frequently. the receiver is not hot ?
Iam at loss!

fizzwater2 08-10-2011 01:18 PM

RE: eratic servo control
 
As a test, try running a separate 4.8 volt to 6 volt receiver battery instead of running off the motor controller.

You might also want to take a small screwdriver handle and gently tap on the receiver while you have the radio operating, see if vibration may be causing problems. It could be an intermittent connection within the receiver.


pn 08-19-2011 07:40 PM

RE: eratic servo control
 
hi
thanks for that ,I am in process of stripping out system and will try a 5v power regulater to supply the reciever as i do not want yet another battery on board, already have 2 12v systems, hope fully try tonight


All times are GMT -8. The time now is 03:16 AM.


Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.