RCU Forums

RCU Forums (https://www.rcuniverse.com/forum/)
-   RC Radios, Transmitters, Receivers, Servos, gyros (https://www.rcuniverse.com/forum/rc-radios-transmitters-receivers-servos-gyros-157/)
-   -   esc problem no power!! (https://www.rcuniverse.com/forum/rc-radios-transmitters-receivers-servos-gyros-157/3599540-esc-problem-no-power.html)

coops1 11-29-2005 01:02 PM

esc problem no power!!
 
Just wondered if anyone knows how to get my esc to power up it is a tower pro 30amp brushless jobbie from ebay and i cant get any power from it!! I got power to the servos via the esc but nothing to the motor, no light or anything (there is no switch to turn it on either) it is suposed to bleep after i plug the battery in with the throttle in the up position but it won't do anything, ive tried it in every channel on the receiver/ hanset and tried reversing all the chanels and still nothing!! I don't know what to do next.
Would the servos work, ie would power still get to the receiver through it if it was dead?
Would it blow if i accidently touched the positive negative terminals together whilst powered up? there is a posability i may have done this whilst plugging the battery in!! But there is still power going through it to the receiver? Any ideas?

delman 11-29-2005 06:31 PM

RE: esc problem no power!!
 
Check to see if your throttle needs to be reversed or plug reversed in receiver - also had to use max throttle trim on one esc along with max throttle to arm it.

coops1 11-30-2005 11:45 AM

RE: esc problem no power!!
 
ive tried reversing the throttle and ive tried all the channels on the handset too in both forward and reverse!

coops1 12-04-2005 10:58 AM

RE: esc problem no power!!
 
and tried full trim with full throttle too, does my TX not have enough forward throttle to arm it or something? it is quite an old futaba.


All times are GMT -8. The time now is 12:35 PM.


Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.