Go Back  RCU Forums > RC Cars, Buggies, Trucks, Tanks and more > RC On Road Nitro Cars
Reload this Page >

First nitro vehicle - very, VERY nearly a driver. Help?

Notices
RC On Road Nitro Cars Discuss all aspects of on-road nitro rc cars here

First nitro vehicle - very, VERY nearly a driver. Help?

Old 06-29-2020, 10:36 PM
  #1  
LagBox505
Junior Member
Thread Starter
 
Join Date: Jun 2020
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Default First nitro vehicle - very, VERY nearly a driver. Help?

Hello, new to nitro but not to hobby RC. Have been fixing up an OFNA OB4 for the past couple months. I replaced iffy parts and added a new traxxas pro .15 cause I wanted a pull start.

Only once so far, I ran the car for about 30 minutes. It was fast, got to probably 40mph or so. The engine appeared to be running cool and strong. I can almost always start the engine, but once it's at temperature it will stall and not want to restart. In addition, It normally isn't making enough power to move the car above about 15mph either.

In addition, after a small amount of running, the engine appears to settle rearwards, causing the clutch bell to mesh so tightly with the 2-speed that it won't turn.

Help me get this beast running! I don't think I can post photos, as this is my first post. It's a cool car!

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.