Notices
RC On Road Nitro Cars Discuss all aspects of on-road nitro rc cars here

problems with rs4

Old 12-02-2003, 04:49 PM
  #1  
paintballer24891
Junior Member
Thread Starter
 
Join Date: Feb 2006
Location: Port Chester, NY
Posts: 8
Likes: 0
Received 0 Likes on 0 Posts
Default problems with rs4

i got my 4sr like 4 months ago and it was runing fine until the problems started first the car turned slightly left and was harder to control i couldnt figure out wat the problem was i could realy use some help
and the clutch bell keeps on ringing and when i tighten the screw i run it and after 5 tanks of gas it starts ringing againi could realy use some help
Old 12-02-2003, 08:37 PM
  #2  
soccerismylife
Senior Member
 
soccerismylife's Avatar
 
Join Date: Sep 2003
Location: San Diego, CA
Posts: 211
Likes: 0
Received 0 Likes on 0 Posts
Default RE: problems with rs4

Adjust the steering trim on your transmitter.
Old 12-02-2003, 11:07 PM
  #3  
rodrigo1508
Senior Member
 
rodrigo1508's Avatar
 
Join Date: Jun 2003
Location: QueretaroQueretaro, MEXICO
Posts: 614
Likes: 0
Received 0 Likes on 0 Posts
Default RE: problems with rs4

sorry to tell you but you wont find a way to go straight every time with this car (at least I couldnt)
You can put some bearings and it may get better
Also the steering servo and its saver are really bad you could buy another with metal gears
Old 12-03-2003, 12:01 AM
  #4  
proptop
My Feedback: (8)
 
proptop's Avatar
 
Join Date: Oct 2002
Location: Rome, NY
Posts: 7,036
Likes: 0
Received 0 Likes on 0 Posts
Default RE: problems with rs4

Yeah, the stock steering isn't exactly precise...There are aftermarket alum. bellcranks w/ ball bearings that will help. Did you use loctite on the clutch retaining screw? You might need to re-do it (clean it well first though)
Old 12-04-2003, 06:30 PM
  #5  
HPInSTL
Junior Member
 
Join Date: Dec 2003
Location: , MO
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Default RE: problems with rs4

I had the same problem with mine. At low speed it would go straight and the faster it went the more it would pull left.

I ended up taking the front and rear diffs apart and relubing them. This ended up working, but I am not sure if it was the diff work that fixed it or just taking the whole car apart that solved the problem.

One simple suggestion is to make sure that none of your wheel nuts are too tight. This can cause some binding on the wheel.

Good luck.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.