Notices
RC On Road Nitro Cars Discuss all aspects of on-road nitro rc cars here

Your NTC3 stalls? Please read

Old 12-07-2003, 04:50 PM
  #1  
spurgear
Member
Thread Starter
 
Join Date: Feb 2003
Location: Freeport, TRINIDAD AND TOBAGO
Posts: 82
Likes: 0
Received 0 Likes on 0 Posts
Default Your NTC3 stalls? Please read

I notice every single time i put my body on my NTC3 and then try to accelerate the engine quits. Why? Even if i just place it on the car with out securing it the engine quits. The engine does not even idle long plus the mixture is set correctly. Please help
Old 12-07-2003, 05:26 PM
  #2  
raceme
Senior Member
 
Join Date: Sep 2003
Location: daly city, CA
Posts: 1,166
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Your NTC3 stalls? Please read

it only happens with the body on
Old 12-07-2003, 05:59 PM
  #3  
spurgear
Member
Thread Starter
 
Join Date: Feb 2003
Location: Freeport, TRINIDAD AND TOBAGO
Posts: 82
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Your NTC3 stalls? Please read

yes only with the body on. There are holes cut out too. One in front, one in the back and one on the side.
Old 12-07-2003, 09:46 PM
  #4  
Nitroaddict
Senior Member
 
Nitroaddict's Avatar
 
Join Date: Jul 2003
Location: Round Rock, TX
Posts: 3,447
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Your NTC3 stalls? Please read

if the engine doesnt idle long, then either the mixture is NOT set correctly or you have a bad glow plug. check the plug first, and if its okay, then u will need to adjust your LSN and/or the ISS.
Old 12-07-2003, 10:59 PM
  #5  
BUGGIES_R_US
 
BUGGIES_R_US's Avatar
 
Join Date: Dec 2002
Location: Norcross, GA
Posts: 3,342
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Your NTC3 stalls? Please read

Well,

If its only with the body, the maybe your body is doing one of the following:

1) air filter is blocked? (fat chance)
2) fuel lines are being pushed against a hot surface or being cut off
3) some servo-body binding proble? (not exactly possible but I thought I could throw it in there)
4) This may sound funny.. but make sure all your CARB SCREWS are there and that they are tight.
Maybe your body is shifting your carb and because its missing a screw.. you have a major air leak with the body on? (happened to me)

ram

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.