Go Back  RCU Forums > RC Cars, Buggies, Trucks, Tanks and more > RC Tanks
Reload this Page >

2 out of 2 defective Henglong 5.3S receivers?

Notices
RC Tanks Discuss all aspects of rc tank building and driving here!

2 out of 2 defective Henglong 5.3S receivers?

Old 02-11-2019, 07:24 AM
  #1  
JREEVES
Thread Starter
My Feedback: (2)
 
JREEVES's Avatar
 
Join Date: Feb 2002
Location: New Port Richey, FL
Posts: 50
Received 0 Likes on 0 Posts
Question 2 out of 2 defective Henglong 5.3S receivers?

The last two Henglong tanks I've received with the latest 2.4gHz, gold label version 5.3S receiver boards have gone rogue. For no apparent reason, I turned on the tanks and the right stick track control has switched from up/down = forward/backwards, to up/down = turn left/right. Forwards/backwards now now requires left/right on the right stick.
Has anyone else experienced this? I've made no changes to either tank and a close inspection of the receiver boards shows no bad solder joints or loose wire connections.
All of my other tanks have the 2.4gHz silver label 5.3 receiver boards and have been very reliable. I'm mystified!
Old 02-12-2019, 05:43 PM
  #2  
AL D
 
AL D's Avatar
 
Join Date: Oct 2008
Posts: 129
Likes: 0
Received 0 Likes on 0 Posts
Default

I think the problem is that the new HL tanks are wired differently - specifically the hull.

I encountered the same problem - ordered two new RX boards (gold plate) from MATO. When I hooked them up to an older HL Tiger, I had the same problem you described. I have a new T-90 that I swapped out the RX's and both new RX's worked perfect. I was looking at the upper hull connections on the new T-90 and it is a different configuration for the electronics.

What I think needs to be done is to rewire/solder the hull bridge on older HL upper hulls so that it coincides with the inputs from the new Transmitter/Rx

Try rewiring the upper hull - pretty sure thats the problem

Hope this helps

AL
Old 02-13-2019, 02:14 PM
  #3  
DirtyBird69
 
DirtyBird69's Avatar
 
Join Date: Nov 2010
Location: Stuart, Fl
Posts: 1,129
Received 0 Likes on 0 Posts
Default

What is the difference with the “gold label” version??
Old 02-13-2019, 03:54 PM
  #4  
JREEVES
Thread Starter
My Feedback: (2)
 
JREEVES's Avatar
 
Join Date: Feb 2002
Location: New Port Richey, FL
Posts: 50
Received 0 Likes on 0 Posts
Default

Originally Posted by DirtyBird69 View Post
What is the difference with the “gold label” version??
THAT sir, is the $64,000 dollar question! I hope AL D is on to something, unfortunately my day job has been getting in the way of investigating this further. Trouble is, when I received my latest HL PanTiger tank with the gold label receiver, it worked fine. Within 2 weeks it suddenly started doing exactly what I described above without me "messing" with anything!
However, when I installed a brand new gold label receiver (which is marked on the circuit board as 5.3S) in a nearly new HL Tiger 1 that had a 5.3 silver label receiver that was troublesome, I had exactly the same problem.
So, it's understandable in the case of my Tiger 1 that the 5.3S receiver is not perfectly compatible with the 5.3 transmitter. However, it isn't understandable that the 5.3S receiver that came with a bound 5.3S transmitter in my PanTiger would do exactly the same thing without my intervention. Confused yet? Here are the circuit boards of the 5.3S and 5.3 transmitters. I don't see an obvious difference.
Old 02-28-2019, 06:02 AM
  #5  
JREEVES
Thread Starter
My Feedback: (2)
 
JREEVES's Avatar
 
Join Date: Feb 2002
Location: New Port Richey, FL
Posts: 50
Received 0 Likes on 0 Posts
Default

So, after a two week wait for new receivers from a chinese vendor on ebay, who assured me they were sending 5.3 silver label units (as pictured in their listing) I received gold label receivers! The vendor apologized and offered a 20% discount. I have no need for their discount!

Looks like I'm in the market for at least one 5.3 silver label receiver, again! Anyone want to swap for a brand new gold label receiver???
Old 02-28-2019, 10:59 AM
  #6  
Imex-Erik
 
Imex-Erik's Avatar
 
Join Date: Mar 2013
Location: Brooksville , FL
Posts: 3,189
Received 26 Likes on 24 Posts
Default


Looking for something like this guy? I know you are down in NPR, but if you got a bit of time to head this way up to Brooksville you can just come pick it up today I would offer to meet you closer but I'm heading North after work and tomorrow I'm heading to CFLFPV for the weekend most likely. PM me if this one is what you need, I'll get rid of it cheap.
Old 02-28-2019, 03:28 PM
  #7  
JREEVES
Thread Starter
My Feedback: (2)
 
JREEVES's Avatar
 
Join Date: Feb 2002
Location: New Port Richey, FL
Posts: 50
Received 0 Likes on 0 Posts
Default

PM sent! Thanks Erik!
Old 09-25-2019, 09:13 PM
  #8  
Lew_Zee
Junior Member
 
Join Date: Sep 2019
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default

Checkout my video for a quick - easy fix. It worked for my T-26 Pershing after I replaced the rec/trans from silver to gold. (It took a few months.) This site said I could not post a url until after 10 posts, but if you want it just use just cut and paste the address in your browser (take out spaces): https :// youtu.be /fwRxB7VrPbw

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright © 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.