Go Back  RCU Forums > RC Cars, Buggies, Trucks, Tanks and more > RC Tanks
Reload this Page >

Need help with new Elmod Fusion Pro board.

Notices
RC Tanks Discuss all aspects of rc tank building and driving here!

Need help with new Elmod Fusion Pro board.

Old 02-27-2020, 06:02 PM
  #1  
Mono67
Junior Member
Thread Starter
 
Join Date: Oct 2019
Location: Central Missouri.
Posts: 5
Likes: 0
Received 0 Likes on 0 Posts
Default Need help with new Elmod Fusion Pro board.

Hello to all,
I need a little advice about my Taigen Tiger 1 all metal with airsoft. I finally pulled the pin on a new board as the original Taigen V3 was lacking due to the upgrade to a Taranis Q7XS. I finally went with an Elmod Fusion Pro. Install went well and I was setting up the parameters for my profile. Well out of nowhere I noticed the status LEDs went from blue, to red and blue solid at the same time. The manual says this indicates a problem with the sound card and thus I have no sound. When I remove the sound card and put it in the computer it shows all the different vehicle types so it obviously is loaded on the card. However, on the Elmod app it shows no current sample set and will not list any options from the drop down menu. Controls now seem out of sorts too. Any ideas?
Eric.
Old 02-28-2020, 09:02 AM
  #2  
smittyrob
 
smittyrob's Avatar
 
Join Date: Jan 2008
Location: Abbotsford, BC, CANADA
Posts: 307
Likes: 0
Received 2 Likes on 2 Posts
Default

Hi,
Is your battery fully charged? I've had issues with mine when using a battery that's not fully charged. Did you try updating the firmware for the sound card? Again I've had some issues with the firmware files just recently.
I had an issue similar to yours, I had no sound or movement from the board. When I used the Elmod app to update the firmware there was only 1 file available and I kept getting update failed messages, but when I used the older Elmod configurator program there were several files showing to choose from and they worked.
You can try to contact Dominique at Rctank.de for help if you still can't get anywhere.
Old 02-28-2020, 06:52 PM
  #3  
Mono67
Junior Member
Thread Starter
 
Join Date: Oct 2019
Location: Central Missouri.
Posts: 5
Likes: 0
Received 0 Likes on 0 Posts
Default Need help with new Elmod Fusion Pro board.

Thanks Smittyrob! After I posted about my issue I found your post about the problem you were having. Sure sounded the same. I only had the turret turning and cannon elevating and firing with no sound. I downloaded the older sound firmware onto a new SD card and all is good. I wonder what the real issue is with the original preloaded SD card? It's odd it worked so well at first then went to pot. I haven't looked closely at the sound files to see what we maybe missing from the older version file to the newest one. I wonder if the problem is a bad card or the content on it? I might fool around and see if I can somehow get the latest version to work. Then again, I have a tendency to screw things up if I think about it too much! I tend to think myself stupid. At any rate, thanks so much. I was worried I may have fried an expensive board somehow (always my main fear).
Cheers!
Old 02-28-2020, 09:29 PM
  #4  
smittyrob
 
smittyrob's Avatar
 
Join Date: Jan 2008
Location: Abbotsford, BC, CANADA
Posts: 307
Likes: 0
Received 2 Likes on 2 Posts
Default

Glad you could get it to work. I had that same feeling you did, I thought I ruined the board. I have 3 of the 3 ton truck boards with different firmware versions on them and from what I can see there is no difference with function or available sounds.
One thing i'm not sure about with the fusion tank board is that when I slowly increase the throttle on the stick the tank will start to move but the sound sometimes jumps to a higer revving engine noise.
I don't know if this is normal, but it doesn't sound very good.

Rob

Last edited by smittyrob; 02-28-2020 at 09:33 PM.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.