Go Back  RCU Forums > RC Cars, Buggies, Trucks, Tanks and more > RC Truggy
Reload this Page >

acme condor won't drive PLEASE HELP!

Notices
RC Truggy Trucks and buggies together make a truggy. Discuss all things truggy right here.

acme condor won't drive PLEASE HELP!

Old 04-02-2020, 03:20 PM
  #1  
olit777
Junior Member
Thread Starter
 
Join Date: Apr 2020
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Default acme condor won't drive PLEASE HELP!

hi I have got an acme condor pro nitro buggy which I have managed to get running but won't go anywhere I have put a new aluminium clutch in and still won't go anywhere I have tightened all the grub screws on the drive shaft joints and stripped everything down and rebuilt it tightening everything as I went and still no luck the bell housing is moving and it is moving both gears but the car will not move it just revs up but if I turn the car off and move the bell housing by hand it moves the gears and the wheels move so it makes no sense to me it's like as soon as the engine is running it's turing the gears but no drive everything looks like it's working but obviously somthing is wrong maybe gearbox slipper clutch? I loosened it and it drives but takes off strait away on start up and really struggles to start so that can't be right but I think it must have somthing to do with the slipper clutch any help would be great it's driving me mad and don't want to start buying loads of parts unless I can pin point the problem thank you for reading and ideas would be much appreciated

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.