Go Back  RCU Forums > RC Cars, Buggies, Trucks, Tanks and more > RC Truggy
Reload this Page >

Hot Bodies Lightning Pro Truggy Engine Mount Question Please Help.SOME1 PLZ LOT OF VIEWS Few replies

Notices
RC Truggy Trucks and buggies together make a truggy. Discuss all things truggy right here.

Hot Bodies Lightning Pro Truggy Engine Mount Question Please Help.SOME1 PLZ LOT OF VIEWS Few replies

Old 04-12-2010, 12:31 AM
  #1  
IROC-AR15
Senior Member
Thread Starter
My Feedback: (10)
 
Join Date: Apr 2010
Location: Columbia, MO
Posts: 223
Likes: 0
Received 0 Likes on 0 Posts
Default Hot Bodies Lightning Pro Truggy Engine Mount Question Please Help.SOME1 PLZ LOT OF VIEWS Few replies

I just got a Dynamite Mach 2 BigRed pullstart/pinstart .28 engine and i am having trouble getting it mounted. The rear edges of the pullstart are rubbing the purple motor mount adapters and cause me not to be able to get the motor level. A member on here told me to use engine mount spacers but i can't find any. Where can I find some of these perhaps? All Ikeep finding on ebay are spacers for the Ofna Hyper 7 buggy
Old 04-12-2010, 04:31 PM
  #2  
nitrofishing
Junior Member
 
Join Date: Jan 2009
Location: prospect hill, NC
Posts: 20
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Hot Bodies Lightning Pro Truggy Engine Mount Question Please Help.SOME1 PLZ LOT OF VIEWS Few replies

Dude, I have had lighting stadiun truggy for a few years and i have had the same problems. All you need are some washers to lift the motor or make a spacer plate under the motor mounts, which may involve using longer screws. The best setup of course is to take the pullstart off and use a backplate and a starter box. Let me know how it goes.
Old 04-13-2010, 02:25 AM
  #3  
IROC-AR15
Senior Member
Thread Starter
My Feedback: (10)
 
Join Date: Apr 2010
Location: Columbia, MO
Posts: 223
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Hot Bodies Lightning Pro Truggy Engine Mount Question Please Help.SOME1 PLZ LOT OF VIEWS Few replies

somebody else told me to use some washer but my problem is with the pullstart rubbing either side of the purple mount plates that go on the chassis.If it level on one side it rubs on the other and vice versa. Describe what i should do cause i want to drive so bad I have washers but don't see how that will work cause its not the starter rubbing the chassis that is the problem
Old 04-13-2010, 11:57 AM
  #4  
IROC-AR15
Senior Member
Thread Starter
My Feedback: (10)
 
Join Date: Apr 2010
Location: Columbia, MO
Posts: 223
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Hot Bodies Lightning Pro Truggy Engine Mount Question Please Help.SOME1 PLZ LOT OF VIEWS Few replies

bump
Old 04-20-2010, 01:53 AM
  #5  
acexxxoasis
Senior Member
My Feedback: (4)
 
acexxxoasis's Avatar
 
Join Date: Aug 2004
Location: milwaukee, WI
Posts: 1,045
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Hot Bodies Lightning Pro Truggy Engine Mount Question Please Help.SOME1 PLZ LOT OF VIEWS Few replies

stack em evenly under the engines mount ears on each screw until it clears
Old 04-21-2010, 02:06 AM
  #6  
IROC-AR15
Senior Member
Thread Starter
My Feedback: (10)
 
Join Date: Apr 2010
Location: Columbia, MO
Posts: 223
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Hot Bodies Lightning Pro Truggy Engine Mount Question Please Help.SOME1 PLZ LOT OF VIEWS Few replies

Ro Ro Rodger Thank thank you

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell or Share My Personal Information -

Copyright © 2023 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.