RCU Forums - Search Results

Go Back  RCU Forums > Search Forums
Reload this Page >

Search Results

Notices
 
Search: Posts Made By: SteveP2
Showing results 1 to 25 of 81
Search took 0.67 seconds.
04-26-2003, 01:40 PM
Replies: 5
Views: 639
Posted By SteveP2

Same Problem?

Thanks for the message AJM. Odd, because Mike Mayberry, at HiTech assures me that he's never come across a problem like mine before :)

Steve P.
Replies: 0
Views: 302
Posted By SteveP2

Idle Up 'stuck' on Hi Tech Eclipse 7

The 'idle on' warning seems to be stuck, on my Hitch Eclipse 7 radio. I have switched the Flt. mode switch back, but it makes no difference. Whatever model setting I use, it comes on, so long as the...
Replies: 2
Views: 585
Posted By SteveP2

Idle Up 'stuck' on Hi Tech Eclipse 7

The 'idle on' warning seems to be stuck, on my Hitch Eclipse 7 radio. I have switched the Flt. mode switch back, but it makes no difference. Whatever model setting I use, it comes on, so long as the...
04-20-2003, 03:47 PM
Replies: 5
Views: 639
Posted By SteveP2

Idle Up 'stuck' on Hi Tech Eclipse 7

The 'idle on' warning seems to be stuck, on my Hitch Eclipse 7 radio. I have switched the Flt. mode switch back, but it makes no difference. Whatever model setting I use, it comes on, so long as the...
04-20-2003, 12:00 PM
Replies: 1
Views: 422
Posted By SteveP2

CSM V.10 simulator - re-setting defaults?

Can anyone advise me if there is a simple way to re-set the defaults on the CSM V.10 simulator? I have changed the crash limit settings, and I can't remember what they used to be!

If there's no...
04-20-2003, 11:59 AM
Replies: 0
Views: 241
Posted By SteveP2

CSM simulator - re-setting defaults?

Can anyone advise me if there is a simple way to re-set the defaults on the CSM V.10 simulator? I have changed the crash limit settings, and I can't remember what they used to be!

If there's no...
03-17-2003, 09:48 AM
Replies: 4
Views: 860
Posted By SteveP2

Main Gear Teeth Missing!

Hi Syclic

Thanks for the reply. Once again, you have it dead on! Just prior to noticing the teeth missing, the T/R had hit the ground, albeit a very thick, soft surface designed to cushion your...
03-16-2003, 11:54 PM
Replies: 4
Views: 860
Posted By SteveP2

Main Gear Teeth Missing!

My Hawk IV started making a clicking noise today, when I started the engine after a minor 'crash'. The blades had struck soft ground when I sent it into a right side landing from about 1 foot high...
03-11-2003, 08:21 PM
Replies: 3
Views: 803
Posted By SteveP2

Hawk Starter Shaft Problem

The Hex adaptor at the top of the starter shaft on my Hawk IV is frequently working loose. I can hardly get one start out of it without having to take out the grub screws and re-tighten the adapter....
03-09-2003, 12:11 AM
Replies: 4
Views: 688
Posted By SteveP2

Nobody told me how to land!

All the books talk about first hovers, and eights and circuits and stuff, but very few tell you how to land safely.

Can someone talk me through a safe and controlled landing sequence - without too...
03-07-2003, 09:31 AM
Replies: 1
Views: 400
Posted By SteveP2

Venture 30 against Hawk IV - Any Views

I'm seriously considering buying the Venture 30 ARF as a second and better Heli. I already own a Century Hawk VI, which has had a few problems even though it's new and hardly flown.

Will the...
03-04-2003, 09:23 PM
Replies: 4
Views: 912
Posted By SteveP2

Pardon?

If I knew what you meant, and how to fix it, I'd do something :(

I'd like to campaign for simple English on this forum - so that those of us who want to learn to fly these things can get help...
03-03-2003, 10:11 AM
Replies: 4
Views: 912
Posted By SteveP2

Starting Problem Hawk IV

I took my Hawk IV out yesterday to practice hovering. I started it once and it hovered quite well, but the training gear came loose and I tried to stop it using the 'cut' button on my Eclipse 7...
03-03-2003, 10:08 AM
Replies: 18
Views: 1,509
Posted By SteveP2

Starting Problem

I took my Hawk IV out yesterday to practice hovering. I started it once and it hovered quite well, but the training gear came loose and I tried to stop it using the 'cut' button on my Eclipse 7...
02-28-2003, 07:31 PM
Replies: 18
Views: 1,509
Posted By SteveP2

Time Passes and we learn

I started this thread about 2 months ago, just as I was buying my first heli, the Hawk IV. Since then, it's been built, rebuilt by an expert (because I made several basic mistakes and it was...
01-30-2003, 05:30 PM
Replies: 8
Views: 942
Posted By SteveP2

Thanks Payton

Thanks for the detailed reply Payton. I'm sure that, on careful study, it will get me further down the road (or up in the air). I have a few points in reply:

1. The start shaft problem may be...
Forum: Glow Engines
01-29-2003, 10:10 AM
Replies: 8
Views: 607
Posted By SteveP2

simple enough

Thanks Protop

Yes, that was very understandable. The problem with vibration is in the fuel tank (usually called 'foaming', I think). So it looks like I have to isloate and insulate, as advised.
...
Forum: Glow Engines
01-29-2003, 10:10 AM
Replies: 8
Views: 607
Posted By SteveP2

simple enough

Thanks Protop

Yes, that was very understandable. The problem with vibration is in the fuel tank (usually called 'foaming', I think). So it looks like I have to isloate and insulate, as advised.
...
01-28-2003, 10:12 PM
Replies: 25
Views: 2,575
Posted By SteveP2

Small Item Missing = BIG Century Let Down!

Hmmmm? That would be...ME!

That field box sound cool, how's the metal on your hands in the cold?

Fine, it has a plastic handle and a padded shoulder strap. It looks like something you see rock...
Forum: Glow Engines
01-28-2003, 10:06 PM
Replies: 8
Views: 607
Posted By SteveP2

err...

Errr...no, they are on the internet, using a forum, like you and me. :rolleyes:

Steve
01-28-2003, 04:29 PM
Replies: 13
Views: 1,279
Posted By SteveP2

Hawk all over!!

The experienced pilot who did the final build and first flight on my Hawk IV, also complained that it was very unstable at first. I'll ask him what he changed, but he did say that the head linkages...
01-28-2003, 04:21 PM
Replies: 25
Views: 2,575
Posted By SteveP2

Small Item Missing = BIG Century Let Down!

Thanks for the tip, bdtsr.

I did get a slow expoxy, and a rapid one made by Araldite. I'm using niether one, as the final build was done by my LHS. My brand new aluminium field box is full of an...
Forum: Glow Engines
01-28-2003, 12:39 AM
Replies: 8
Views: 607
Posted By SteveP2

Newbie Question: Enriching the mixture

How do make the mixture 'richer' on my .36 ABC heli engine, without messing up its idle or stop it running smoothly?

I have a vibration in the fuel tank, and I've been told to make the mix richer...
01-28-2003, 12:32 AM
Replies: 8
Views: 942
Posted By SteveP2

Richening the mixture

Can someone advise on the simple way to do this without messing things up (when it comes to engines I'm a helluva banjo player!)

Steve
01-26-2003, 11:08 PM
Replies: 6
Views: 551
Posted By SteveP2

DOS CMS?

It definitely runs under win 98, and there's a patch for XP (whixh is on my laptop), too.

Steve
Showing results 1 to 25 of 81
 


 
Forum Jump

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.