RCU Forums - Search Results

Go Back  RCU Forums > Search Forums
Reload this Page >

Search Results

Notices
Search: Posts Made By: Nator
Showing results 1 to 5 of 5
Search took 0.12 seconds.
Forum: Beginners
09-21-2011, 04:08 AM
Replies: 16
Views: 976
Posted By Nator

RE: Beginner Setup Issues

"Quote:
Looks like you still have a poor connection somewhere."

I'm a little puzzled by this. It was my understanding that with a prop the motor draws more amps, because of the increase in...
Forum: Beginners
09-20-2011, 03:51 PM
Replies: 16
Views: 976
Posted By Nator

RE: Beginner Setup Issues

Hi All,
First off, thanks for all of the suggestions. They were a great help to this rookie. I think I have found the issue, and it was a combination of two things. The first issue was the...
Forum: Beginners
09-20-2011, 04:22 AM
Replies: 16
Views: 976
Posted By Nator

RE: Beginner Setup Issues

The motor I am using right now pulls 10A (15 Burst) with a 9x4.5 prop. As for the Jet, I am not 100% on that. Since I am new, I don't have all of the tools to measure capacities and usage, but if it...
Forum: Beginners
09-19-2011, 06:34 PM
Replies: 16
Views: 976
Posted By Nator

RE: Beginner Setup Issues

Hi, thanks for the quick response. I charged it with a charger with the light. I tried the battery in another plane with a motor rating of 3500kv (a jet) which worked fine, and is why I thought it...
Forum: Beginners
09-19-2011, 05:29 PM
Replies: 16
Views: 976
Posted By Nator

Beginner Setup Issues

Hello All,
I am pretty new to the electric RCPlane game and am having some issues with my plane. I had just recharged my battery after a rather successful flight. When Itry and start my plane...
Showing results 1 to 5 of 5


 
Forum Jump

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.