Go Back  RCU Forums > Search Forums
Reload this Page >

Search Results

Notices
 
Search: Posts Made By: mclassic
Showing results 1 to 25 of 66
Search took 0.74 seconds.
09-16-2004, 06:51 PM
Replies: 36
Views: 2,459
Posted By mclassic

RE: Sent my LST back to Losi...

First, I would never sell anything to someone knowing something was wrong with it.

As far as the issues with the truck, I'm definitely not blaming Losi for some bad assumptions I made. I did...
09-16-2004, 11:11 AM
Replies: 36
Views: 2,459
Posted By mclassic

RE: Sent my LST back to Losi...

Yeah, a hydro-locked engine is the cause of my LST's engine/transmission problems. The problem isn't with starting the engine. It starts just fine. You should also know that I'm not the only one...
09-15-2004, 09:36 PM
Replies: 36
Views: 2,459
Posted By mclassic

RE: Sent my LST back to Losi...

No, I'm not looking for sympathy. I talked to Losi about the engine two weeks ago stating that I would like to send it back. They offered some suggestions, which didn't resolve the issues. So, I...
09-15-2004, 03:30 PM
Replies: 36
Views: 2,459
Posted By mclassic

RE: Sent my LST back to Losi...

I have taken the tranny apart. I have taken the engine apart. I would not go through all the trouble to send it back to Losi if I was able to solve the problems myself. I have also had a number of...
09-15-2004, 02:41 PM
Replies: 36
Views: 2,459
Posted By mclassic

RE: Sent my LST back to Losi...

Believe me, I have had a number of people between two LHS's look at my truck. They haven't been able to do anything with it. So, it went back to Losi.
09-15-2004, 02:13 PM
Replies: 36
Views: 2,459
Posted By mclassic

Sent my LST back to Losi...

After 7 weeks of ownership, and no success at getting my LST to run properly, through my own doing, or with the help of others, I shipped my LST back to Losi along with a nice letter stating to them...
09-10-2004, 08:36 AM
Replies: 578
Views: 50,747
Posted By mclassic

RE: Before i order my factory team ntc3....

On my local track I run 42 shore foam tires up front and 35 shore rear. My car does really well with this setup. Problem is, that my rear tires are torn up and the only thing I have left are 40 shore...
09-07-2004, 02:38 PM
Replies: 6
Views: 671
Posted By mclassic

RE: mach engine.....what do you think

I think a faulty Mach engine was included with my LST. I'm very upset about having to buy another engine. I'm more inclined to sell my LST then shell out some nice cash for a new engine.

Do...
08-31-2004, 10:46 PM
Replies: 19
Views: 1,013
Posted By mclassic

RE: Mach .26 good or bad

The Mach 26 is straight garbage in my opinion. I'm highly annoyed with mine. This thing is almost impossible to tune. It constantly runs hot. I have no low-end throttle whatsoever. I'm not...
08-30-2004, 01:51 PM
Replies: 2
Views: 693
Posted By mclassic

What type of fuel do you use?

Just wanted to get an idea of what type of fuel everyone is running.

1.) type of fuel
2.) Nitro/Oil mixture
3.) Effect on needle settings (if any).
4.) Any special mods to engine (fuel...
08-29-2004, 03:15 PM
Replies: 1
Views: 716
Posted By mclassic

LST clutch questions

I need to know how noticeable is the LST's shift into second gear? I ran it my local track yesterday and everyone agreed that it wasn't shifting and wasn't going as fast as it should.

I took...
08-23-2004, 09:16 PM
Replies: 29
Views: 1,742
Posted By mclassic

RE: Mixed feelings on LST performance

The LSN is fine. The HSN fitting is solid. But, the HSN assembly was a little loose before I even ran it for the first time. I'll check it again though. Maybe there's a leak there.
08-23-2004, 07:27 PM
Replies: 29
Views: 1,742
Posted By mclassic

RE: Mixed feelings on LST performance

Yup, checked it, everything was okay, same result. Swapped for Ofna springs, same result. Swapped for Mugen shoes and Ofna springs, same result. Checked my slipper.

This thing does not want...
08-23-2004, 07:23 PM
Replies: 43
Views: 2,560
Posted By mclassic

RE: CLUTCH SPRINGS THREAD

1. Ofna springs - (supposedly Mugen 1.0 equivalents)
2. Mugen white teflon shoes
3. I have run 6 tanks with these springs, parking lot driving only, so no final word yet on this setup
4....
08-23-2004, 07:16 PM
Replies: 29
Views: 1,742
Posted By mclassic

RE: Mixed feelings on LST performance

I think I can make a similar assessment about my Mach 26. I think I'll give Losi a call and see if I can send it in so they can take a look. I don't think it's normal to have to rev the engine way...
08-23-2004, 07:12 PM
Replies: 6
Views: 629
Posted By mclassic

RE: I'd never thought I would be a show off!!

very hot! I need to get around to painting my F-150 body. I have barely run my LST, so it's not a priority right now.
08-20-2004, 03:53 PM
Replies: 29
Views: 1,742
Posted By mclassic

RE: Mixed feelings on LST performance

I'm having the same exact issues as creyc. It took me quite a while to get my low speed needle right. The engine definitely comes to life after dialing in the high speed needle. I still don't know...
08-20-2004, 03:47 PM
Replies: 26
Views: 1,390
Posted By mclassic

RE: DOES STOCK LST WHEELIE

Mine has never done a wheelie either. Maybe my engine is set up improperly, or something with my slipper. But, Iit definitely takes off with all four wheels on the ground.
08-18-2004, 08:33 PM
Replies: 18
Views: 1,612
Posted By mclassic

RE: Battery Packs

I ran my LST tonight and I got 5 tanks out of my HPI 1200 pack and it still has a good charge. I think I can get at least 7 tanks out of it.
08-18-2004, 08:28 PM
Replies: 5
Views: 509
Posted By mclassic

A few questions for LST owners

I have a few questions after FINALLY getting my LST to run.

1. Has anyone cut a hole in their front windshield to get air directly to the engine head? Or, does enough air come in through the...
08-18-2004, 08:25 AM
Replies: 49
Views: 2,987
Posted By mclassic

RE: LST settings [your's]

lstfan, I have the same exact issue. I cannot get my truck to move unless I really rev the engine up. By that point, my engine temps shoot up and the truck eventually overheats. I have checked my...
08-16-2004, 07:47 PM
Replies: 31
Views: 1,792
Posted By mclassic

RE: Can't keep my LST engine temps down

engine temps are fine when I dial-in the factory settings. But, I have absolutely no low-end throttle response whatsoever unless I go full throttle with the engine. If I make the low speed needle...
08-15-2004, 11:02 PM
Replies: 9
Views: 889
Posted By mclassic

RE: LST clutch assembly

Thermal, I have taken apart the two-speed transmission high/low gear and found nothing but a lot of grease in there. I didn't do any cleaning.

Are you saying I should also disassemble the...
08-15-2004, 10:35 PM
Replies: 9
Views: 889
Posted By mclassic

RE: LST clutch assembly

Thanks for the info. Where can I purchase these shoes and springs.

Also, what has everyone's experience been with the LST's low end throttle response. I have to rev my engine quite a bit to...
08-15-2004, 05:51 PM
Replies: 9
Views: 889
Posted By mclassic

RE: LST clutch assembly

I have Ofna springs on the shoes and they're really tight. Snortonrustler and I tried it out today and the truck just won't move unless I max out the throttle.

I don't know what else to try.
Showing results 1 to 25 of 66
 


 
Forum Jump

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.