Go Back  RCU Forums > RC Airplanes > RC Jets > Turbine Clinic > SimJet Turbine Direct Support
Reload this Page >

Simjet 1200 cool down sequence on start up

Notices
SimJet Turbine Direct Support Direct support for SimJet Turbines provided here.

Simjet 1200 cool down sequence on start up

Old 04-10-2017, 08:52 PM
  #1  
davow
Junior Member
Thread Starter
 
Join Date: May 2013
Location: , AUSTRALIA
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
Default Simjet 1200 cool down sequence on start up

Hi,

So I recently got a 1200 that hasn't been used in a while. 9 times out of 10 it will perform a cool down sequence when switched on. Like continually. Red & green flashing light Only very occasionally does it let me proceed to start up. I've tried 3 cell lipo, life and 9.6 nimh. Manual says red and green flashing combustion chamber too hot. Well it's not that at 15 degrees Celsius. Later in the manual, fault 8 says turbine not properly connected to ECU or thermo coupler prob.

So I suppose it could be any of those things and something completely simple.

Any help appreciated. Anyone, anyone.. Bueller

Thank you

Dave
Old 07-06-2017, 04:45 AM
  #2  
Gary Arthur
My Feedback: (29)
 
Gary Arthur's Avatar
 
Join Date: Jan 2002
Location: Hamilton, ON, CANADA
Posts: 1,436
Likes: 0
Received 0 Likes on 0 Posts
Default

Either the TC is bad or the adjustment under the front cover is out of wack. There is a small board the TC connects to that has a adjustment pot.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.