Go Back  RCU Forums > RC Boats > Speed - RC Nitro Boats
 Boat won't start >

Boat won't start

Notices
Speed - RC Nitro Boats For all your rc nitro fuel burning boating needs.

Boat won't start

Old 06-16-2008, 09:40 PM
  #1  
Senior Member
Thread Starter
 
pcg33k's Avatar
 
Join Date: May 2007
Location: Plainfield, IL
Posts: 328
Likes: 0
Received 0 Likes on 0 Posts
Default Boat won't start

Maybe somebody could help me out. My boat won't start I ran it Saturday with no problems as a matter of fact it ran great probably the best its run. Then Sunday I went to the pond again to run her and she wouldn't start. I tried loosening the glow plug to let any extra gas out, tried different glow plugs, tried priming the carb, tried tipping the boat upside down to let any extra fuel out but nothing is working. The only thing left is the glow driver, I'm thinking maybe my glow driver isn't charged up enough so I'm charging it tonight but if this doesn't work then I don't know what else to do. Any help???
Old 06-16-2008, 10:02 PM
  #2  
 
Dreamin Hemi's Avatar
 
Join Date: Nov 2004
Location: Milton, DE
Posts: 2,638
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Boat won't start

From my years of glow powered airplane experiences, your probably correct in your assumption of your glow driver. I'll bet she starts right up once you have it charged!
Old 06-17-2008, 06:15 AM
  #3  
Senior Member
 
vamp131's Avatar
 
Join Date: Jun 2006
Location: Glasgow, UNITED KINGDOM
Posts: 419
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Boat won't start

try your glow plug in the glow starter should be red or if you have a good one bright white hot sounds like your glow plug is dead i went thro 3 on sunday crap not buying them from e bay again lol well did get ten for£10 lol
Old 06-17-2008, 07:03 AM
  #4  
 
GRANT ED's Avatar
 
Join Date: Apr 2003
Location: Adelaide, AUSTRALIA
Posts: 2,695
Likes: 0
Received 1 Like on 1 Post
Default RE: Boat won't start

If a glo engine decides not to start the first things to check are ignition and fuel. Make sure its got both. Check the glo plug. Pull it out and look at it. Does it look ok? You said you changed it so thats prob not an issue. Make sure ur glo driver works. I have to charge mine every day. I cant use it one day, leave it overnight and use it again.
Charge your driver and try again. If its still no good then we'll look at fuel. Let us know how you go.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On


Thread Tools
Search this Thread

Contact Us - Manage Preferences Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.