Go Back  RCU Forums > RC Helicopters > Electric RC Helis > T-Rex heli
 Cx 450SE V2 tail rudder stopped working. any ideas? >

Cx 450SE V2 tail rudder stopped working. any ideas?

Notices
T-Rex heli For all you T-Rex lovers out there, this where you can post!

Cx 450SE V2 tail rudder stopped working. any ideas?

Old 01-24-2011, 09:14 AM
  #1  
Member
Thread Starter
 
Join Date: Oct 2010
Location: CorkCork, IRELAND
Posts: 88
Likes: 0
Received 0 Likes on 0 Posts
Default Cx 450SE V2 tail rudder stopped working. any ideas?

Took out my CX today, as usual inspected it visually, set all controls on the tx to neutral ositions and connected up the battery. Gyro initialised and i spooled her up, heli span out of control, yaw input didn't help at all, shut her off... checked the tail rudder and no movement! last time i turned off the heli there was no problem, norma flight, no errors, landed. It's the standard RTF gyro/servo's for now. If it is any help the gro has a constant red light when it is set, and it flashes when i use the yaw controls. Also i don't believe it is a tx/rx problem as the tail doesn't move when i wag the heli, in fact the servo isn't even recieving power. Any thoughts? Thanks!
Old 01-24-2011, 09:38 AM
  #2  
Senior Member
 
Join Date: Feb 2009
Location: Gatineau, QC, CANADA
Posts: 608
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Cx 450SE V2 tail rudder stopped working. any ideas?

Sounds like a Gyro problem to me. What type is it? Is it connected properly in the Receiver? The Tail Servo connected properly to the Gyro?
Old 01-24-2011, 10:47 AM
  #3  
Member
Thread Starter
 
Join Date: Oct 2010
Location: CorkCork, IRELAND
Posts: 88
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Cx 450SE V2 tail rudder stopped working. any ideas?


ORIGINAL: gi1mo2

Sounds like a Gyro problem to me. What type is it? Is it connected properly in the Receiver? The Tail Servo connected properly to the Gyro?
Thanks. It's a ****e copterx gyro, I'll go connect and re-connect everything after, and see if that helps. Can't wait to get a futaba gy401 and some good servo's

Old 01-27-2011, 11:02 AM
  #4  
Member
Thread Starter
 
Join Date: Oct 2010
Location: CorkCork, IRELAND
Posts: 88
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Cx 450SE V2 tail rudder stopped working. any ideas?

Turns out it was a servo problem. can't figure out what, motor is fine, connectons look fine, but its dead
Old 01-27-2011, 02:00 PM
  #5  
Senior Member
 
Join Date: Feb 2009
Location: Gatineau, QC, CANADA
Posts: 608
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Cx 450SE V2 tail rudder stopped working. any ideas?

Yep, connecting the tail servo directly to the receiver to bypass the gyro would have been a good test.
Old 01-27-2011, 03:29 PM
  #6  
Member
Thread Starter
 
Join Date: Oct 2010
Location: CorkCork, IRELAND
Posts: 88
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Cx 450SE V2 tail rudder stopped working. any ideas?

I connected it to a gyro on another choppah! There is a light on the gyro and it was flashing when i gave an input so i took it the gyro was giving commands to the servo so it made sense... thank god it didn't go mid flight :O

Cheers for the help!

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On


Thread Tools
Search this Thread

Contact Us - Manage Preferences Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.