Go Back  RCU Forums > RC Helicopters > Electric RC Helis > T-Rex heli
 Testing my new T-rex 600 LE >

Testing my new T-rex 600 LE

Notices
T-Rex heli For all you T-Rex lovers out there, this where you can post!

Testing my new T-rex 600 LE

Old 01-25-2011, 12:23 AM
  #1  
Senior Member
Thread Starter
 
Join Date: Mar 2010
Location: Dubai, UNITED ARAB EMIRATES
Posts: 100
Likes: 0
Received 0 Likes on 0 Posts
Default Testing my new T-rex 600 LE

<p style="text-align: center">[youtube]http://www.youtube.com/watch?v=DITrRhyxC8o[/youtube]</p>
Old 01-26-2011, 10:08 PM
  #2  
Senior Member
 
Cleared2Engage's Avatar
 
Join Date: Mar 2007
Location: Oxnard, CA
Posts: 602
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Testing my new T-rex 600 LE

I think you may have punctured your LiPo battery! There's smoke trailing out of that thing!!!
J/K, really nice flying.
Old 02-01-2011, 09:11 PM
  #3  
Senior Member
My Feedback: (21)
 
Join Date: Oct 2007
Location: shelby twp, MI
Posts: 733
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Testing my new T-rex 600 LE

Looking good,what servos are you testing?

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On


Thread Tools
Search this Thread

Contact Us - Manage Preferences Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.