Go Back  RCU Forums > RC Helicopters > Electric RC Helis > T-Rex heli
 75 amp Align ESC failed or not? >

75 amp Align ESC failed or not?

Notices
T-Rex heli For all you T-Rex lovers out there, this where you can post!

75 amp Align ESC failed or not?

Old 08-27-2011, 06:35 AM
  #1  
Thread Starter
 
Join Date: Jul 2005
Location: Brighton, AUSTRALIA
Posts: 53
Received 1 Like on 1 Post
Default 75 amp Align ESC failed or not?

Does anyone know how to test Align Speed controllers? A have had a 75 amp esc in a scale bell222 body with Trex600 mechanics, for about 3 years. Always ran faultless. Until recently, it started to get minor power surges, and then they would dissapear. On the last flt, the surges dissapeared, but it lost all power gradually. Managed to auto onto the deck, but one l/g leg collapsed, and the tail rotor struck the dirt, stripping the drive gears. Such a ***** working on scale helis!
Any ideas for testing the esc?
Old 08-27-2011, 07:24 AM
  #2  
Senior Member
 
Rob2160's Avatar
 
Join Date: Jun 2010
Location: Sydney, AUSTRALIA
Posts: 4,786
Likes: 0
Received 0 Likes on 0 Posts
Default RE: 75 amp Align ESC failed or not?


ORIGINAL: millsy144

Does anyone know how to test Align Speed controllers? A have had a 75 amp esc in a scale bell222 body with Trex600 mechanics, for about 3 years. Always ran faultless. Until recently, it started to get minor power surges, and then they would dissapear. On the last flt, the surges dissapeared, but it lost all power gradually. Managed to auto onto the deck, but one l/g leg collapsed, and the tail rotor struck the dirt, stripping the drive gears. Such a ***** working on scale helis!
Any ideas for testing the esc?
Can't really help with how to test the ESC, but I have been having exactly the same problem with a Hobbywing Pentium 40 Amp esc..

It is in a 450 Pro TT clone that has been flawless for around 200 flights..

In the past few weeks it had a couple of minor surges, more like glitches, and today, it just seems to be losing power.. the heli was previously "unboggable" (if that makes sense.. ) now it bogs quite badly with maximum pitch...

I also noticed both the motor and the ESC are extremely hot where they previously ran very cool..

I guess it just happens sometimes.. Like anything mechanical or electrical.. they just wear out..
Old 08-27-2011, 07:43 PM
  #3  
Thread Starter
 
Join Date: Jul 2005
Location: Brighton, AUSTRALIA
Posts: 53
Received 1 Like on 1 Post
Default RE: 75 amp Align ESC failed or not?

Yer, I have just ordered a 100amp align from Watts up rc. See if that cures it. Pic attached of heli.
Cheers
Old 08-28-2011, 04:12 PM
  #4  
Senior Member
 
Cleared2Engage's Avatar
 
Join Date: Mar 2007
Location: Oxnard, CA
Posts: 602
Likes: 0
Received 0 Likes on 0 Posts
Default RE: 75 amp Align ESC failed or not?

I had the same issue with mine in a 450 sized MD500E. It ended up being too much heat in the fuselage that killed it. I went from a 25 to a 35 amo esc and put some more cooling holes in the fuselage, and the problem went away. Got enough cooling on your triple 2?

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On


Thread Tools
Search this Thread

Contact Us - Manage Preferences Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.